summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD36
-rw-r--r--pam_ldap-reproducible.patch24
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..81e0de6894e2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pam_ldap
+ pkgdesc = LDAP authentication module for the PAM framework
+ pkgver = 186
+ pkgrel = 10
+ url = http://www.padl.com/OSS/pam_ldap.html
+ arch = x86_64
+ license = LGPL
+ depends = libldap
+ depends = pam
+ options = !makeflags
+ backup = etc/pam_ldap.conf
+ source = https://sources.archlinux.org/other/packages/pam_ldap/pam_ldap-186.tar.gz
+ source = pam_ldap-reproducible.patch
+ md5sums = 58c8689921c5c4578363438acd8503c2
+ md5sums = a79a0629fe04eaa350e0a94f00dde7c8
+
+pkgname = pam_ldap
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6461dc927e6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer:
+# Contributor: Comete <la_comete@tiscali.fr>
+
+pkgname=pam_ldap
+pkgver=186
+pkgrel=10
+pkgdesc="LDAP authentication module for the PAM framework"
+arch=('x86_64')
+url="http://www.padl.com/OSS/pam_ldap.html"
+license=('LGPL')
+depends=('libldap' 'pam')
+backup=('etc/pam_ldap.conf')
+options=('!makeflags')
+#source=("https://www.padl.com/download/${pkgname}-${pkgver}.tar.gz")
+source=("https://sources.archlinux.org/other/packages/pam_ldap/$pkgname-$pkgver.tar.gz" "pam_ldap-reproducible.patch")
+md5sums=('58c8689921c5c4578363438acd8503c2'
+ 'a79a0629fe04eaa350e0a94f00dde7c8')
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ patch -Np1 -i ${srcdir}/pam_ldap-reproducible.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --libdir=/usr/lib \
+ --with-ldap-conf-file=/etc/pam_ldap.conf \
+ --mandir=/usr/share/man
+ PERL5LIB="$PWD" PATH="${PATH}:${srcdir}/${pkgname}-${pkgver}" make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/etc/ldap.conf" "${pkgdir}/etc/pam_ldap.conf"
+}
diff --git a/pam_ldap-reproducible.patch b/pam_ldap-reproducible.patch
new file mode 100644
index 000000000000..4d5bbd462da6
--- /dev/null
+++ b/pam_ldap-reproducible.patch
@@ -0,0 +1,24 @@
+diff -aur pam_ldap-186.old/vers_string pam_ldap-186/vers_string
+--- pam_ldap-186.old/vers_string 2021-12-29 21:45:36.010231609 +0100
++++ pam_ldap-186/vers_string 2021-12-29 22:24:03.167959325 +0100
+@@ -3,17 +3,19 @@
+ #ident $Id: vers_string,v 1.2 2010/02/25 14:40:39 lukeh Exp $
+ #
+ # Implementation of SGS vers_string which uses CVSVersionInfo.txt.
++use POSIX qw(strftime);
++
+
+ require "cvslib.pl";
+
+ $OUTFILE = (-f "version.h") ? "version.h" : "vers.c";
+ $AUTHOR = `whoami`;
+ $HEADER = '$Id: vers_string,v 1.2 2010/02/25 14:40:39 lukeh Exp $';
++$DATE = strftime("%Y-%m-%d", gmtime($ENV{SOURCE_DATE_EPOCH} || time));
+
+ if ($ENV{'PROGRAM'}) { $PROGRAM = $ENV{'PROGRAM'}; }
+
+ chop($AUTHOR);
+-chop($DATE=`date -u`);
+ chop($CWD=`pwd`);
+
+ ($PROJECT, $VERSION) = split(/\-/, &getCVSVersionInfo());