summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD31
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..97cd46767e7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = paperdesktop-git
+ pkgdesc = An awesome Desktop Environment built on top of Qt/Wayland and wayfire.
+ pkgver = r127.960ff1e
+ pkgrel = 1
+ url = https://gitlab.com/cubocore/paper/
+ arch = any
+ groups = paperdesktop-git
+ license = GPL3
+ makedepends = git
+ depends = qt5-base
+ depends = qt5-wayland
+ depends = qt5-connectivity
+ depends = qt5-svg
+ depends = udisks2
+ depends = wayfire
+ depends = libdbusmenu-qt5
+ provides = paperdesktop
+ conflicts = paperdesktop
+ source = git+https://gitlab.com/cubocore/paper/paperdesktop.git
+ md5sums = SKIP
+
+pkgname = paperdesktop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cafc706527f9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+_pkgname=paperdesktop
+pkgname=${_pkgname}-git
+pkgver=r127.960ff1e
+pkgrel=1
+pkgdesc="An awesome Desktop Environment built on top of Qt/Wayland and wayfire."
+arch=('any')
+url="https://gitlab.com/cubocore/paper/"
+license=('GPL3')
+depends=('qt5-base' 'qt5-wayland' 'qt5-connectivity' 'qt5-svg' 'udisks2' 'wayfire' 'libdbusmenu-qt5')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+groups=('paperdesktop-git')
+source=("git+https://gitlab.com/cubocore/paper/${_pkgname}.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/${_pkgname}"
+ qmake-qt5 ${_pkgname}.pro
+ make
+}
+
+package() {
+ cd "$srcdir/${_pkgname}"
+ make INSTALL_ROOT=${pkgdir} install
+}