summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD33
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d9dc384c3a49
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = parcittox-svn
+ pkgdesc = Adds the possibility to share clips over the network between Linux (running Parcittox) and Windows (running Ditto) PCs
+ pkgver = r43
+ pkgrel = 1
+ url = https://app.assembla.com/spaces/dittox/wiki#
+ arch = x86_64
+ license = GPL3
+ makedepends = intltool
+ depends = libappindicator-gtk2
+ conflicts = parcittox
+ conflicts = parcellite
+ source = parcittox::svn+https://subversion.assembla.com/svn/dittox/
+ sha256sums = SKIP
+
+pkgname = parcittox-svn
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e43743940fdb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Dimitris Kiziridis <ragouel at outlook dot com>
+
+pkgname=parcittox-svn
+pkgver=r43
+pkgrel=1
+pkgdesc='Adds the possibility to share clips over the network between Linux (running Parcittox) and Windows (running Ditto) PCs'
+arch=('x86_64')
+url='https://app.assembla.com/spaces/dittox/wiki#'
+license=('GPL3')
+conflicts=('parcittox' 'parcellite')
+depends=('libappindicator-gtk2')
+makedepends=('intltool')
+source=("${pkgname%-svn}::svn+https://subversion.assembla.com/svn/dittox/")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname%-svn}/trunk/parcittox/"
+ local ver="$(svnversion)"
+ printf "r%s" "${ver//[[:alpha:]]}"
+}
+
+build() {
+ cd "${pkgname%-svn}/trunk/parcittox/"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${pkgname%-svn}/trunk/parcittox/"
+ make DESTDIR="${pkgdir}" install
+}
+# vim:set ts=2 sw=2 et: \ No newline at end of file