summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD24
-rw-r--r--pass-paste.install13
-rw-r--r--release-notes.txt17
5 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b189f8cf3eed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pass-paste
+ pkgdesc = An extension for pass: paste passwords by mouse without clipboard.
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/loh-tar/pass-paste
+ install = pass-paste.install
+ changelog = release-notes.txt
+ arch = any
+ license = GPL
+ depends = pass
+ depends = xorg-server
+ depends = xdotool
+ depends = xorg-xwininfo
+ depends = xorg-xprop
+ source = pass-paste-0.8.1.tar.gz::https://github.com/loh-tar/pass-paste/archive/v0.8.1.tar.gz
+ sha256sums = 200835f41514b9ed730d47266a2a70ffb7c2d35f1f1a8c52293526f311fdf731
+
+pkgname = pass-paste
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..23d13e098571
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/pkg
+/src
+*.tar.gz
+*.tar.xz
+*.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e8c2d4aaf09d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: loh.tar <loh.tar at googlemail dot com>
+pkgname='pass-paste'
+pkgver='0.8.1'
+pkgrel='1'
+pkgdesc='An extension for pass: paste passwords by mouse without clipboard.'
+arch=('any')
+url="https://github.com/loh-tar/$pkgname"
+license=('GPL')
+# namcap complains nothing of these are needed(?)
+depends=('pass' 'xorg-server' 'xdotool' 'xorg-xwininfo' 'xorg-xprop')
+install="$pkgname.install"
+changelog="release-notes.txt"
+source=("$pkgname-$pkgver.tar.gz::https://github.com/loh-tar/$pkgname/archive/v$pkgver.tar.gz")
+sha256sums=('200835f41514b9ed730d47266a2a70ffb7c2d35f1f1a8c52293526f311fdf731')
+
+prepare() {
+ # Update/Copy/Fetch release-notes/changelog It's not possible to referenz above direct
+ cp "$pkgname-$pkgver/release-notes.txt" ../
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make install DESTDIR="$pkgdir"
+}
diff --git a/pass-paste.install b/pass-paste.install
new file mode 100644
index 000000000000..c256e13e1ed4
--- /dev/null
+++ b/pass-paste.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo -e "*\n* Hint: You may need to ensure that the completion file is 'sourced' at shell invocation\n*"
+}
+
+post_upgrade() {
+ # Well, I agree that, if every package would print such hint, it would be annoying.
+ # But 1) noobs like me didn't know that feature 2) I tried some packages, but without success
+ # Let's promote this cool feature :-)
+
+ [ $1 == $2 ] && return # Nothing todo, looks like reinstall
+ [ "${1%-*}" == "${2%-*}" ] && return # Still Nothing todo, looks like pkg fix only
+ echo -e "*\n* TIP! Look at the release notes what may new or is fixed: pacman -Qc pass-paste\n*"
+}
diff --git a/release-notes.txt b/release-notes.txt
new file mode 100644
index 000000000000..c5ef60b81fdc
--- /dev/null
+++ b/release-notes.txt
@@ -0,0 +1,17 @@
+Release notes to pass-paste version v0.8, Feb 2022
+====================================================
+Hello World!
+
+We start with 0.8 because it's feature complete, except the flaws noted at
+TODO/BUGS, See online https://github.com/loh-tar/pass-paste
+
+Version 1.0 should support Wayland and at least zsh shell completion
+
+
+Notes to patch version v0.8.1, Feb 2022
+-----------------------------------------
+a58cb89 - Suppress rare error message when bring window to front
+================================================================================
+No previous release
+--------------------------------------------------------------------------------
+The full changelog is here: https://github.com/loh-tar/pass-paste/commits/master