summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--Makefile8
-rw-r--r--PKGBUILD21
4 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cf1fc585aaa1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pastify
+ pkgdesc = A command line pastbin service helper
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/ryanmaynard/pastify
+ arch = any
+ license = MIT
+ depends = curl
+ provides = pastify
+ source = pastify-1.0.0.tar.gz::https://github.com/ryanmaynard/pastify/archive/v1.0.0.tar.gz
+ sha256sums = aa17f4a40b68a2943d2a21f07ae888fca21f523a0df0db09c1df7608d5876ae1
+
+pkgname = pastify
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ea1fbe5c421
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*gz
+*xz
+pkg/
+src/
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..579cdc75e109
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,8 @@
+clean:
+ rm -f *xz
+ rm -f *gz
+ rm -rf src
+ rm -rf pkg
+
+srcinfo:
+ makepkg --printsrcinfo > .SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d00dcf9b896
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Bobby Burden III <bobby@brb3.org>
+pkgname=pastify
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A command line pastbin service helper"
+arch=("any")
+url="https://github.com/ryanmaynard/pastify"
+license=("MIT")
+depends=("curl")
+makedepends=()
+provides=("pastify")
+source=(
+"${pkgname}-${pkgver}.tar.gz::https://github.com/ryanmaynard/pastify/archive/v${pkgver}.tar.gz"
+)
+sha256sums=("aa17f4a40b68a2943d2a21f07ae888fca21f523a0df0db09c1df7608d5876ae1")
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm755 "pastify.sh" "${pkgdir}/usr/bin/pastify"
+}