summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD19
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3727eeaabaa8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pb-go
+ pkgdesc = A golang-based simple and powerful pastebin server named pb-go
+ pkgver = 1.0.5
+ pkgrel = 1
+ url = https://github.com/pb-go/pb-go
+ arch = x86_64
+ license = AGPL3
+ makedepends = xz
+ options = !strip
+ source = https://github.com/pb-go/pb-go/releases/download/v1.0.5/pb-go-linux-amd64.xz
+ sha256sums = 7efbc440c6fafa078a24a40c52341e1481a7a01af8573d576483d6ffd3418032
+
+pkgname = pb-go
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a56f9f6dfd66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Patrick Young <16604643+kmahyyg@users.noreply.github.com>
+pkgname=pb-go
+pkgver=1.0.5
+pkgrel=1
+pkgdesc="A golang-based simple and powerful pastebin server named pb-go"
+arch=('x86_64')
+url="https://github.com/pb-go/pb-go"
+license=('AGPL3')
+makedepends=('xz')
+options=("!strip")
+source=(
+ "https://github.com/pb-go/pb-go/releases/download/v${pkgver}/pb-go-linux-amd64.xz"
+)
+sha256sums=(
+ '7efbc440c6fafa078a24a40c52341e1481a7a01af8573d576483d6ffd3418032'
+)
+package() {
+ install -Dm755 "pb-go-linux-amd64" "${pkgdir}/usr/bin/pb-go"
+}