summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD53
-rw-r--r--license24
3 files changed, 93 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ebc9e1068080
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pcc-libs-cvs
+ pkgdesc = Libraries for the Portable C Compiler.
+ pkgver = 20170701
+ pkgrel = 1
+ url = http://pcc.ludd.ltu.se/
+ arch = i686
+ arch = x86_64
+ license = custom
+ makedepends = cvs
+ provides = pcc-libs
+ conflicts = pcc-libs
+ source = license
+ md5sums = 51f6cc02b26af53f26cfe87494ca5c87
+
+pkgname = pcc-libs-cvs
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6ba5b4380da0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Contributor: Andreas Baumann <abaumann at yahoo dot com>
+# Contributor: Chris Brannon <cmbrannon (at) cox.net>
+
+pkgname=pcc-libs-cvs
+pkgver=20170701
+pkgrel=1
+pkgdesc="Libraries for the Portable C Compiler."
+arch=('i686' 'x86_64')
+url="http://pcc.ludd.ltu.se/"
+license=('custom')
+provides=(pcc-libs)
+conflicts=(pcc-libs)
+makedepends=('cvs')
+source=(license)
+md5sums=('51f6cc02b26af53f26cfe87494ca5c87')
+
+pkgver() {
+ date '+%Y%m%d'
+}
+
+_cvsroot=":pserver:anonymous@pcc.ludd.ltu.se:/cvsroot"
+_cvsmod="pcc-libs"
+build() {
+ cd "$srcdir"
+
+ msg "Connecting to pcc.ludd.ltu.se CVS server (module $_cvsmod)...."
+ if [ -d $_cvsmod/CVS ]; then
+ cd $_cvsmod
+ cvs -z3 update -d
+ else
+ cvs -z3 -d $_cvsroot co -D $pkgver -f $_cvsmod
+ cd $_cvsmod
+ fi
+
+ msg "CVS checkout done or server timeout"
+ msg "Starting make..."
+
+ rm -rf "$srcdir/$_cvsmod-build"
+ cp -r "$srcdir/$_cvsmod" "$srcdir/$_cvsmod-build"
+ cd "$srcdir/$_cvsmod-build"
+
+ ./configure --prefix=/usr || return 1
+
+ make CC=gcc || return 1
+}
+
+package() {
+ cd "$srcdir/$_cvsmod-build"
+
+ make DESTDIR=$pkgdir install || return 1
+
+ install -D -m0644 ${srcdir}/license ${pkgdir}/usr/share/licenses/${pkgname}/license
+}
diff --git a/license b/license
new file mode 100644
index 000000000000..027142c525a2
--- /dev/null
+++ b/license
@@ -0,0 +1,24 @@
+ Copyright (c) 2004 Anders Magnusson (ragge@ludd.luth.se).
+ All rights reserved.
+
+ Redistribution and use in source and binary forms, with or without
+ modification, are permitted provided that the following conditions
+ are met:
+ 1. Redistributions of source code must retain the above copyright
+ notice, this list of conditions and the following disclaimer.
+ 2. Redistributions in binary form must reproduce the above copyright
+ notice, this list of conditions and the following disclaimer in the
+ documentation and/or other materials provided with the distribution.
+ 3. The name of the author may not be used to endorse or promote products
+ derived from this software without specific prior written permission
+
+ THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR
+ IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
+ OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
+ IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
+ INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
+ NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+ DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+ THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+ (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
+ THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.