summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
-rw-r--r--pce-ibmpc.patch131
3 files changed, 138 insertions, 1 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e7e37b157aa4..4708371c3894 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -56,6 +56,7 @@ pkgbase = pce-git
source = http://www.hampa.ch/pce/rom/rc759/rc759-1-5.1.rom
source = http://www.hampa.ch/pce/rom/rc759/rc759-2-4.0.rom
source = http://www.hampa.ch/pce/rom/rc759/rc759-2-5.1.rom
+ source = pce-ibmpc.patch
sha512sums = SKIP
sha512sums = 64a90a40473ef340c429a76f12b23c4d7cceee808abc23d8cd54a977afdef7ae8a96918462450aed9b8dce578a4690982dd21fe39ac69e60c780bd90fbff11ac
sha512sums = 2fafd22868033fb6e0c01644dc7b70ef4155ccff909eae6e1ba882087134595afde21f126d37e4bdda343eeae54580e4df7d9b7ba6f917cc61dcc9e9aa4996f2
@@ -96,5 +97,6 @@ pkgbase = pce-git
sha512sums = 0086c238b47df27a92d6b42e3b7288e38fd8cdfa7fbe8683e4c875bdc2497b5f3642eb95dc75d0912272e92da428bdcc5ff5576c15c87a1809df35b9bc09b106
sha512sums = 3926e96914e55f977c5da397671a84523e14a93e1d0d0ae46df8466e4a7da42ed146bb2441bfc88445083fa6d9e339cf9b734489ec29ac7b7c71970ae4405504
sha512sums = 61e5402000725497b26fc608161c222ad945087638c245b8e20ec475d880c826658627f404fc05d1cc06a0e348ab6be6812c883a6372531f0f053f04babe65ad
+ sha512sums = 30a041dd73c85de6c4169dd92bdfbfe680326749907757a13eb567135087ddee99fdaae1b86fcffcc89e2e91fd3de08076d537b25dc7fc03a872dadadcdef76d
pkgname = pce-git
diff --git a/PKGBUILD b/PKGBUILD
index 92edc61da319..534468b236b6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -53,6 +53,7 @@ source=(
"${url}/rom/rc759/rc759-1-5.1.rom"
"${url}/rom/rc759/rc759-2-4.0.rom"
"${url}/rom/rc759/rc759-2-5.1.rom"
+ 'pce-ibmpc.patch'
)
sha512sums=('SKIP'
'64a90a40473ef340c429a76f12b23c4d7cceee808abc23d8cd54a977afdef7ae8a96918462450aed9b8dce578a4690982dd21fe39ac69e60c780bd90fbff11ac'
@@ -93,7 +94,8 @@ sha512sums=('SKIP'
'7538472a1abd85cd4635d2301e7a2add24bf808ad8d2d2e6b38ee18e0c1971f35fd71450f10c17f1e22c6dbf30fef038dc7dae383ca94c9bfe78224f750711ad'
'0086c238b47df27a92d6b42e3b7288e38fd8cdfa7fbe8683e4c875bdc2497b5f3642eb95dc75d0912272e92da428bdcc5ff5576c15c87a1809df35b9bc09b106'
'3926e96914e55f977c5da397671a84523e14a93e1d0d0ae46df8466e4a7da42ed146bb2441bfc88445083fa6d9e339cf9b734489ec29ac7b7c71970ae4405504'
- '61e5402000725497b26fc608161c222ad945087638c245b8e20ec475d880c826658627f404fc05d1cc06a0e348ab6be6812c883a6372531f0f053f04babe65ad')
+ '61e5402000725497b26fc608161c222ad945087638c245b8e20ec475d880c826658627f404fc05d1cc06a0e348ab6be6812c883a6372531f0f053f04babe65ad'
+ '30a041dd73c85de6c4169dd92bdfbfe680326749907757a13eb567135087ddee99fdaae1b86fcffcc89e2e91fd3de08076d537b25dc7fc03a872dadadcdef76d')
pkgver() {
#ln -sf BambuStudio "BambuStudio"
@@ -116,6 +118,8 @@ package() {
mkdir -p "${pkgdir}/usr/share/${_pkgname}"
mv "${pkgdir}/usr/etc/pce" "${pkgdir}/usr/share/${_pkgname}/config"
rm -rf "${pkgdir}/usr/etc"
+ cd "${pkgdir}/usr/share/${_pkgname}/config"
+ patch -p0 < "$srcdir/pce-ibmpc.patch"
# install doc files
mkdir -p "$pkgdir/usr/share/doc/${_pkgname}"
diff --git a/pce-ibmpc.patch b/pce-ibmpc.patch
new file mode 100644
index 000000000000..59ab6e3192f4
--- /dev/null
+++ b/pce-ibmpc.patch
@@ -0,0 +1,131 @@
+--- pce-ibmpc.cfg.orig 2023-06-30 15:21:33.814803824 -0400
++++ pce-ibmpc.cfg 2023-06-30 16:36:30.813460122 -0400
+@@ -17,6 +17,7 @@
+ # is added to the beginning of the search path.
+ path = "rom"
+ path = "/usr/share/pce/ibmpc"
++path = "/usr/share/pce/video"
+ path = "-."
+
+
+@@ -80,7 +81,7 @@
+ cpu {
+ # The CPU model.
+ # Recognized models are: 8086, 8088, 80186, 80188
+- model = "80186"
++ model = "8088"
+
+ # This sets the CPU speed with respect to the emulated
+ # system clock. A value of 1 emulates a 4.77MHz CPU.
+@@ -126,14 +127,14 @@
+ # The main BIOS
+ format = "binary"
+ address = 0xfe000
+- file = "ibm-pc-1982.rom"
++ file = "ibm-pc-1982-10-27.rom"
+ }
+
+ load {
+ # The ROM BASIC
+ format = "binary"
+ address = 0xf6000
+- file = "basic-1.10.rom"
++ file = "ibm-basic-1.10.rom"
+ }
+
+ load {
+@@ -262,7 +263,7 @@
+ address = 0xc0000
+ size = 32768
+ default = 0xff
+- file = "ibmvga.rom"
++ file = "ibm-vga.rom"
+ }
+ }
+
+@@ -291,7 +292,7 @@
+ address = 0xc0000
+ size = 16384
+ default = 0xff
+- file = "ibmega.rom"
++ file = "ibm-ega.rom"
+ }
+ }
+
+@@ -402,9 +403,9 @@
+ sample_rate = 44100
+
+ #driver = "null"
+- #driver = "wav:wav=speaker.wav:lowpass=0:wavfilter=0"
++ #driver = "wav:wav=/tmp/speaker.wav:lowpass=0:wavfilter=0"
+ #driver = "oss:dev=/dev/dsp:wav=speaker.wav:lowpass=0:wavfilter=0"
+- driver = "sdl:wav=speaker.wav:lowpass=0:wavfilter=0"
++ driver = "sdl:wav=/tmp/speaker.wav:lowpass=0:wavfilter=0"
+ }
+
+
+@@ -456,14 +457,14 @@
+ # all platforms.
+ #driver = "mouse:xmul=1:xdiv=1:ymul=1:ydiv=1"
+ #driver = "null"
+- #driver = "posix:file=serport1.out"
++ #driver = "posix:file=/tmp/serport1.out"
+ #driver = "pty:symlink=com1"
+- driver = "stdio:file=serport1.out:flush=1"
++ driver = "stdio:file=/tmp/serport1.out:flush=1"
+ #driver = "tios:file=/dev/ttyS0"
+ #driver = "tcp:port=5555:telnet=1:telnetinit=1:usectl=1"
+
+ # Log all traffic to this file. This is for debugging.
+- #log = "serport1.log"
++ #log = "/tmp/serport1.log"
+ }
+
+ serial {
+@@ -480,14 +481,14 @@
+ # LPT1
+ address = 0x378
+
+- driver = "stdio:file=parport1.out"
++ driver = "stdio:file=/tmp/parport1.out"
+ }
+
+ parport {
+ # LPT2
+ address = 0x278
+
+- driver = "stdio:file=parport2.out"
++ driver = "stdio:file=/tmp/parport2.out"
+ }
+
+
+@@ -505,13 +506,13 @@
+ # it does not exist.
+ # Setting this is equivalent to setting a write image and
+ # not setting a read image.
+- file = "cas1.pti"
++ file = "/tmp/cas1.pti"
+
+ # The read tape image.
+- #read = "cas1.pti
++ #read = "/tmp/cas1.pti
+
+ # The write tape image.
+- #write = "cas1.pti"
++ #write = "/tmp/cas1.pti"
+ }
+
+
+@@ -557,9 +558,9 @@
+ # The hard disk BIOS
+ format = "binary"
+ address = 0xc8000
+- file = "ibm-hdc-1985-10-28.rom"
+- # file = "sms-hdc-1986.rom"
+- # file = "dtc-hdc-1988-05-31.rom"
++ file = "ibm-xebec-hdc-1985.rom"
++ # file = "dtc-hdc-1988.rom"
++ # MISSING file = "sms-hdc-1986.rom"
+ }
+
+ # The XT hard disk controller