summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile.Arch1
-rw-r--r--PKGBUILD10
-rw-r--r--pdftk.install10
-rw-r--r--pdftk.sh1
4 files changed, 20 insertions, 2 deletions
diff --git a/Makefile.Arch b/Makefile.Arch
index d0247daf0d33..b5fb6299d819 100644
--- a/Makefile.Arch
+++ b/Makefile.Arch
@@ -3,6 +3,7 @@
export CXX= g++-6.3
export GCJ= gcj-6.3
+export GIJ= gij-6.3
export GCJH= gcjh-6.3
export GJAR= gjar-6.3
export CC1PLUS= cc1plus-6.3
diff --git a/PKGBUILD b/PKGBUILD
index f5a7a38116ec..2339dc35d733 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pdftk
pkgver=2.02
-pkgrel=12
+pkgrel=13
pkgdesc="Pdftk is a simple tool for doing everyday things with PDF documents"
arch=('i686' 'x86_64')
url="http://www.pdfhacks.com/pdftk"
@@ -14,9 +14,12 @@ depends=('gcc63-gcj' 'gcc-gcj-ecj')
options=('!makeflags')
source=("http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/${pkgname}-${pkgver}-src.zip"
"Makefile.Arch"
+ "pdftk.sh"
)
+install=pdftk.install
sha1sums=('a4a27e984c5e1401cfa44b8e92a64113d7396a06'
- '7052d81754b99a4ef3a8c8dbe749886f2fb2159e')
+ '50da68be80a2ed9cf9ae2c24d0016ea19f0eec0d'
+ '764ed416147731567a0876b835204f4469b39ea1')
prepare() {
cd "$srcdir/$pkgname-$pkgver-dist/$pkgname"
@@ -44,4 +47,7 @@ package() {
# Install manpage
install -D -m 644 "pdftk.1" "$pkgdir/usr/share/man/man1/pdftk.1"
+
+ # Install script to set env variables.
+ install -D -m 755 "${srcdir}/pdftk.sh" "${pkgdir}/etc/profile.d/pdftk.sh"
}
diff --git a/pdftk.install b/pdftk.install
new file mode 100644
index 000000000000..e37a4c35abd8
--- /dev/null
+++ b/pdftk.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo "The pdftk binary needs LD_LIBRARY_PATH=/lib/gcc/x86_64-pc-linux-gnu/6.3.1"
+ echo "You thus need to relogin in order for pdftk to work properly"
+}
+
+post_upgrade() {
+ if [ $(vercmp $2 2.02-13) -lt 0 ]; then
+ post_install
+ fi
+}
diff --git a/pdftk.sh b/pdftk.sh
new file mode 100644
index 000000000000..80f167c64f73
--- /dev/null
+++ b/pdftk.sh
@@ -0,0 +1 @@
+export LD_LIBRARY_PATH=${LD_LIBRARY_PATH}:/lib/gcc/x86_64-pc-linux-gnu/6.3.1