summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD32
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..117e95c16bc6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 6.0.1
+# Fri Mar 11 07:20:27 UTC 2022
+pkgbase = peeq
+ pkgdesc = A Postgresql client with programmer utilities.
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/dbhowell/peeq
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = granite
+ depends = gtksourceview3
+ depends = postgresql-libs
+ conflicts = peeq-bin
+ conflicts = peeq-git
+ source = https://github.com/dbhowell/peeq/archive/refs/tags/0.6.1.tar.gz
+ sha256sums = 27596c000e70f6d1f11e5fd1d7a827752d16658de1816d290cdc0fc9a8979679
+
+pkgname = peeq
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6940957496e0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+pkgname=peeq
+pkgver=0.6.1
+pkgrel=1
+pkgdesc="A Postgresql client with programmer utilities."
+arch=(x86_64)
+url=https://github.com/dbhowell/peeq
+license=(GPL3)
+depends=(granite gtksourceview3 postgresql-libs)
+makedepends=(git meson vala)
+source=("${url}/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('27596c000e70f6d1f11e5fd1d7a827752d16658de1816d290cdc0fc9a8979679')
+conflicts=(peeq-bin peeq-git)
+
+build () {
+ sed -i "s/dependency('libpq'),/meson.get_compiler('vala').find_library('libpq'),/" "${pkgname}-${pkgver}/src/meson.build"
+ arch-meson "${pkgname}-${pkgver}" build
+ # Trigger a project conversion from vala to c
+ ninja -C build src/com.github.dbhowell.peeq.p/Application.c
+ # Fix headers and linker for Archlinux
+ sed -i 's|<postgresql/libpq-fe.h>|<libpq-fe.h>|' \
+ build/src/com.github.dbhowell.peeq.p/Services/Connection.c \
+ build/src/com.github.dbhowell.peeq.p/Utils/DataFormat.c \
+ build/src/com.github.dbhowell.peeq.p/Services/QueryResult.c
+ sed -i 's|/usr/lib/libz.so|/usr/lib/libz.so /usr/lib/libpq.so|' build/build.ninja
+ # Finally make a full build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" ninja -C build install
+}