summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD35
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..42b2ba3d3713
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-check-isa
+ pkgdesc = This module provides several functions to assist in testing whether a value is an object, and if so asking about its class.
+ pkgver = 0.09
+ pkgrel = 1
+ url = https://metacpan.org/release/Check-ISA
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/M/MA/MANWAR/Check-ISA-0.09.tar.gz
+ md5sums = SKIP
+
+pkgname = perl-check-isa
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a99066c69c5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: awe00 < awe00 AT hotmail DOT fr>
+pkgname=perl-check-isa
+pkgver=0.09
+pkgrel=1
+pkgdesc='This module provides several functions to assist in testing whether a value is an object, and if so asking about its class.'
+_dist=Check-ISA
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+makedepends=()
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/M/MA/MANWAR/$_dist-$pkgver.tar.gz")
+md5sums=("SKIP")
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}