summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD71
2 files changed, 39 insertions, 43 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3441f584db63..f7327a8bf46d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,14 @@
-# Generated by mksrcinfo v8
-# Fri Nov 17 19:30:19 UTC 2017
pkgbase = perl-clone-pp
pkgdesc = Clone::PP - Recursively copy Perl datatypes
- pkgver = 1.07
+ pkgver = 1.08
pkgrel = 1
- url = http://search.cpan.org/dist/Clone-PP/
+ url = https://metacpan.org/pod/Clone::PP
arch = any
license = GPL
license = PerlArtistic
depends = perl
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Clone-PP-1.07.tar.gz
- sha256sums = bf85e109b7d9a10677db82fa65c1720ae95499a49cbb676d4b3d1b183786b395
+ source = https://cpan.metacpan.org/authors/id/N/NE/NEILB/Clone-PP-1.08.tar.gz
+ sha256sums = 57203094a5d8574b6a00951e8f2399b666f4e74f9511d9c9fb5b453d5d11f578
pkgname = perl-clone-pp
-
diff --git a/PKGBUILD b/PKGBUILD
index 1f744d4aca0c..eee12ef425f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,51 +1,50 @@
-# Maintainer: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
+# Maintainer: Moritz Bunkus <moritz@bunkus.org>
-pkgname=perl-clone-pp
-pkgver=1.07
-pkgrel=1
-_author=N/NE/NEILB
-_perlmod=Clone-PP
+pkgname="perl-clone-pp"
+pkgver="1.08"
+pkgrel="1"
pkgdesc='Clone::PP - Recursively copy Perl datatypes'
arch=('any')
-url="http://search.cpan.org/dist/Clone-PP/"
+url="https://metacpan.org/pod/Clone::PP"
license=('GPL' 'PerlArtistic')
groups=()
-depends=(perl)
+depends=("perl")
makedepends=()
provides=()
conflicts=()
replaces=()
-options=(!emptydirs)
-source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
-sha256sums=('bf85e109b7d9a10677db82fa65c1720ae95499a49cbb676d4b3d1b183786b395')
-unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
-export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps MODULEBUILDRC=/dev/null
-build(){
- cd "$srcdir"/$_perlmod-$pkgver
+options=("!emptydirs")
+source=("https://cpan.metacpan.org/authors/id/N/NE/NEILB/Clone-PP-${pkgver}.tar.gz")
+sha256sums=('57203094a5d8574b6a00951e8f2399b666f4e74f9511d9c9fb5b453d5d11f578')
- if [ -r Makefile.PL ]; then
- /usr/bin/perl Makefile.PL
- make
- elif [ -r Build.PL ]; then
- perl Build.PL
- ./Build
- fi
+prepare_environment() {
+ export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+ cd "${srcdir}/Clone-PP-${pkgver}"
}
-check(){
- cd "$srcdir"/$_perlmod-$pkgver
- if [ -r Makefile.PL ]; then
- make test
- elif [ -r Build.PL ]; then
- ./Build test
- fi
+build() {
+ prepare_environment
+ /usr/bin/perl Makefile.PL
+ make
}
-package(){
- cd "$srcdir"/$_perlmod-$pkgver
- if [ -r Makefile.PL ]; then
- make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
- elif [ -r Build.PL ]; then
- ./Build install --installdirs=vendor --destdir="$pkgdir"
- fi
+check() {
+ prepare_environment
+ make test
}
+
+package() {
+ prepare_environment
+ make install
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: