summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD50
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0d71ad481ce8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = perl-if
+ pkgdesc = use a Perl module if a condition holds
+ pkgver = 0.0601
+ pkgrel = 2
+ url = http://search.cpan.org/dist/if
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/I/IL/ILYAZ/modules/if-0.0601.tar.gz
+ md5sums = 3a19abc96d20a47f6dafd7b29ff5383e
+ sha512sums = 1eb73d19b13270824b5e690eec18add1487cc07e370cb283a514b7343ac6609916e843f80a3d9e06d58652fe770974d65cd4c5a1121f213751e99caae68b9d7f
+
+pkgname = perl-if
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81b2502a13be
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-if'
+pkgver='0.0601'
+pkgrel='2'
+pkgdesc="use a Perl module if a condition holds"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl')
+makedepends=()
+url='http://search.cpan.org/dist/if'
+source=('http://search.cpan.org/CPAN/authors/id/I/IL/ILYAZ/modules/if-0.0601.tar.gz')
+md5sums=('3a19abc96d20a47f6dafd7b29ff5383e')
+sha512sums=('1eb73d19b13270824b5e690eec18add1487cc07e370cb283a514b7343ac6609916e843f80a3d9e06d58652fe770974d65cd4c5a1121f213751e99caae68b9d7f')
+_distdir="if-0.0601"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Makefile.PL
+ make
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ make test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ make install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: