summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index deef28885182..1445ea91e81c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,3 +1,5 @@
+# Generated by mksrcinfo v8
+# Tue Feb 28 01:05:09 UTC 2017
pkgbase = perl-math-convexhull-monotonechain
pkgdesc = Math::ConvexHull::MonotoneChain - Andrew's monotone chain algorithm for finding a convex hull in 2D
pkgver = 0.01
diff --git a/PKGBUILD b/PKGBUILD
index 5e5302f6d9a5..0cb9d4c4fdc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -16,29 +16,26 @@ options=(!emptydirs)
#install=
source=("http://search.cpan.org/CPAN/authors/id/S/SM/SMUELLER/Math-ConvexHull-MonotoneChain-${pkgver}.tar.gz")
md5sums=('eaac1a9350f914fea5bbce2029b95b57')
+_src_dir='$srcdir/Math-ConvexHull-MonotoneChain-$pkgver'
-prepare() {
- export _src_dir="$srcdir/Math-ConvexHull-MonotoneChain-$pkgver"
+build() {
# Setting these env variables overwrites any command-line-options we don't want...
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
MODULEBUILDRC=/dev/null
-}
-
-build() {
- cd "$_src_dir"
+ eval cd "$_src_dir"
/usr/bin/perl Makefile.PL
make
}
check () {
- cd "$_src_dir"
+ eval cd "$_src_dir"
make test
}
package () {
- cd "$_src_dir"
+ eval cd "$_src_dir"
make install
# remove perllocal.pod and .packlist