summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5c18fae5f632..78cb3354d101 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,5 @@
pkgbase = perl-memoize-expirelru
+ pkgdesc = Perl/CPAN Module Memoize::ExpireLRU: Expiry plug-in for Memoize that adds LRU cache expiration
pkgver = 0.56
pkgrel = 1
url = https://metacpan.org/release/Memoize-ExpireLRU
@@ -9,5 +10,6 @@ pkgbase = perl-memoize-expirelru
options = !emptydirs
source = http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Memoize-ExpireLRU-0.56.tar.gz
md5sums = 8a8c66e450dfddea7cb9b5a20c94390d
+ sha512sums = 4f19b3149b3ebd2fc7be9320e6bfe60220462dd8ca4a45d2aa22cf938ae763d80c51401ce73309da50c59194559637660432c6630c00846793c7114f8ac00eed
pkgname = perl-memoize-expirelru
diff --git a/PKGBUILD b/PKGBUILD
index 20071e86ef7e..b53233d74daf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,22 @@
-# Maintainer: Michał Wojdyła < micwoj9292 at gmail dot com >
+# Maintainer: int <int [ate] arcor [dot] de>
+# Contributor: Michał Wojdyła < micwoj9292 at gmail dot com >
# Contributor: John D Jones III AKA jnbek <jnbek1972 -_AT_- g m a i l -_Dot_- com>
+# Generator : CPANPLUS::Dist::Arch 1.32
pkgname='perl-memoize-expirelru'
pkgver='0.56'
pkgrel='1'
-pkgdesc=""
+pkgdesc="Perl/CPAN Module Memoize::ExpireLRU: Expiry plug-in for Memoize that adds LRU cache expiration"
arch=('any')
license=('PerlArtistic' 'GPL')
options=('!emptydirs')
depends=('perl')
makedepends=()
url='https://metacpan.org/release/Memoize-ExpireLRU'
-source=('http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Memoize-ExpireLRU-0.56.tar.gz')
+source=("http://search.cpan.org/CPAN/authors/id/N/NE/NEILB/Memoize-ExpireLRU-${pkgver}.tar.gz")
md5sums=('8a8c66e450dfddea7cb9b5a20c94390d')
-_distdir="Memoize-ExpireLRU-0.56"
+sha512sums=('4f19b3149b3ebd2fc7be9320e6bfe60220462dd8ca4a45d2aa22cf938ae763d80c51401ce73309da50c59194559637660432c6630c00846793c7114f8ac00eed')
+_distdir="Memoize-ExpireLRU-${pkgver}"
build() {
( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
@@ -39,7 +42,7 @@ package() {
cd "$srcdir/$_distdir"
make install
- find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+ find "$pkgdir" "(" -name .packlist -o -name perllocal.pod ")" -delete
}
# Local Variables: