summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.AURINFO14
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
3 files changed, 24 insertions, 13 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..7ee5f6c52e7e
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,14 @@
+pkgbase = perl-net-pcaputils
+ pkgdesc = Perl/CPAN Module Net::PcapUtils
+ pkgver = 0.01
+ pkgrel = 3
+ url = https://metacpan.org/release/Net-PcapUtils
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl-net-pcap
+ source = http://cpan.metacpan.org/authors/id/T/TI/TIMPOTTER/Net-PcapUtils-0.01.tar.gz
+ options = !emptydirs
+
+pkgname = perl-net-pcaputils
+
diff --git a/.SRCINFO b/.SRCINFO
index 0cd546013d8b..757824a264c3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,11 @@
pkgbase = perl-net-pcaputils
pkgdesc = Perl/CPAN Module Net::PcapUtils
pkgver = 0.01
- pkgrel = 2
+ pkgrel = 3
url = https://metacpan.org/release/Net-PcapUtils
- arch = i686
- arch = x86_64
+ arch = any
license = GPL
license = PerlArtistic
- depends = perl
- depends = libpcap
- depends = glibc
depends = perl-net-pcap
options = !emptydirs
source = http://cpan.metacpan.org/authors/id/T/TI/TIMPOTTER/Net-PcapUtils-0.01.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 05bd565c32f5..9b5d9f2c3701 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,29 @@
-# Maintainer: Alessandro Nakamuta <alessandro dot nakamuta at archlinux dot com dot br>
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: Alessandro Nakamuta <alessandro dot nakamuta at archlinux dot com dot br>
pkgname=perl-net-pcaputils
_cpanname=Net-PcapUtils
pkgver=0.01
-pkgrel=2
+pkgrel=3
pkgdesc="Perl/CPAN Module Net::PcapUtils"
-arch=("i686" "x86_64")
+arch=('any')
url="https://metacpan.org/release/$_cpanname"
license=("GPL" "PerlArtistic")
options=('!emptydirs')
source=("http://cpan.metacpan.org/authors/id/T/TI/TIMPOTTER/${_cpanname}-${pkgver}.tar.gz")
-depends=('perl' 'libpcap' 'glibc' 'perl-net-pcap')
+depends=('perl-net-pcap')
md5sums=('eeba67266dbe155b504df3c2de1d657f')
build() {
cd "${srcdir}/${_cpanname}-${pkgver}"
# install module in vendor directories.
- PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
- make || return 1
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
+ make
}
package() {
cd "${srcdir}/${_cpanname}-${pkgver}"
- make install DESTDIR="${pkgdir}" || return 1
+ make install DESTDIR="${pkgdir}"
find "$pkgdir" -name '.packlist' -delete
find "$pkgdir" -name '*.pod' -delete