summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD6
2 files changed, 7 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c58bb16d86fa..92c021676af6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,14 @@
pkgbase = perl-quota
pkgdesc = Quota - Perl interface to file system quotas
pkgver = 1.7.2
- pkgrel = 1
+ pkgrel = 2
url = https://metacpan.org/release/Quota
arch = any
license = GPL
license = PerlArtistic
depends = perl
+ depends = libtirpc
+ depends = rpcsvc-proto
options = !emptydirs
options = purge
source = http://search.cpan.org/CPAN/authors/id/T/TO/TOMZO/Quota-1.7.2.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 5d3a53dfabf7..17bb775612a3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Contributor: Daniel Café <dccafe@gmail.com>
pkgname=perl-quota
pkgver=1.7.2
-pkgrel=1
+pkgrel=2
pkgdesc='Quota - Perl interface to file system quotas'
_dist=Quota
arch=('any')
url="https://metacpan.org/release/$_dist"
license=('GPL' 'PerlArtistic')
-depends=(perl)
+depends=('perl' 'libtirpc' 'rpcsvc-proto')
options=('!emptydirs' purge)
source=("http://search.cpan.org/CPAN/authors/id/T/TO/TOMZO/$_dist-$pkgver.tar.gz")
md5sums=(d4ed0acc56ece4e5080a7a6d827e9c66)
@@ -17,6 +17,8 @@ build() {
unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
/usr/bin/perl Makefile.PL
+ sed -i 's/-shared/-ltirpc -shared/g' Makefile
+ sed -i 's/usr\/local\/include/usr\/include\/tirpc/g' Makefile
make
}