summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9393dce8830b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = perl-redmine-api
+ pkgdesc = Communicate with Redmine thought the API
+ pkgver = 0.04
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Redmine-API/
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ depends = perl
+ depends = perl-moo
+ depends = perl-rest-client
+ depends = perl-json
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/C/CE/CELOGEEK/Redmine-API-0.04.tar.gz
+ md5sums = 443a3d5bd7dd4a24fd36a2615287147e
+
+pkgname = perl-redmine-api
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cfaa801551f8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+pkgname='perl-redmine-api'
+pkgver=0.04
+pkgrel=1
+pkgdesc="Communicate with Redmine thought the API"
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl' 'perl-moo' 'perl-rest-client' 'perl-json')
+makedepends=()
+url='http://search.cpan.org/dist/Redmine-API/'
+_distdir="Redmine-API-$pkgver"
+source=("http://search.cpan.org/CPAN/authors/id/C/CE/CELOGEEK/Redmine-API-$pkgver.tar.gz")
+md5sums=('443a3d5bd7dd4a24fd36a2615287147e')
+
+build() {
+ cd $srcdir/Redmine-API-$pkgver
+ perl Build.PL installdirs=vendor destdir="$pkgdir/"
+ perl Build
+}
+
+package() {
+ cd $srcdir/Redmine-API-$pkgver
+ perl Build install
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}