summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD35
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..22b1ba2e224e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = perl-uri-redis
+ pkgdesc = URI for Redis connection info
+ pkgver = 0.02
+ pkgrel = 1
+ url = https://metacpan.org/release/URI-redis
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ makedepends = perl-test-most
+ makedepends = perl-module-install
+ depends = perl
+ depends = perl-uri
+ options = !emptydirs
+ options = purge
+ source = http://search.cpan.org/CPAN/authors/id/M/ME/MENDEL/URI-redis-0.02.tar.gz
+ md5sums = ed86ee5019e5e038ee9d8f727a0972e9
+
+pkgname = perl-uri-redis
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3ae9f9cf3f98
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer : Nicolas Guillaumin <nicolas plus archlinux at guillaumin dot me>
+pkgname=perl-uri-redis
+pkgver=0.02
+pkgrel=1
+pkgdesc='URI for Redis connection info'
+_dist=URI-redis
+arch=('any')
+url="https://metacpan.org/release/$_dist"
+license=('GPL' 'PerlArtistic')
+depends=(perl perl-uri)
+makedepends=(perl-test-most perl-module-install)
+options=('!emptydirs' purge)
+source=("http://search.cpan.org/CPAN/authors/id/M/ME/MENDEL/$_dist-$pkgver.tar.gz")
+md5sums=(ed86ee5019e5e038ee9d8f727a0972e9)
+
+build() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
+ /usr/bin/perl Makefile.PL
+ make
+}
+
+check() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ export PERL_MM_USE_DEFAULT=1
+ make test
+}
+
+package() {
+ cd "$srcdir/$_dist-$pkgver"
+ unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
+ make install INSTALLDIRS=vendor DESTDIR="$pkgdir"
+}