summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--PKGBUILD.tt1
3 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be81742b176e..84a780c88ef9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = perl-xml-compile-wsdl11
pkgdesc = Perl package to create SOAP messages defined by WSDL 1.1
- pkgver = 3.07
- pkgrel = 3
+ pkgver = 3.08
+ pkgrel = 1
url = https://metacpan.org/release/XML-Compile-WSDL11
arch = any
license = PerlArtistic
@@ -10,10 +10,10 @@ pkgbase = perl-xml-compile-wsdl11
depends = perl-xml-compile>=1.48
depends = perl-xml-compile-cache>=1.03
depends = perl-xml-compile-soap>=3.23
+ depends = perl-xml-compile-tester
depends = perl-log-report>=1.05
options = !emptydirs
- source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-WSDL11-3.07.tar.gz
- md5sums = 2866c7ef1630b76182deaae36879b9f8
+ source = http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-WSDL11-3.08.tar.gz
+ md5sums = 2ff6f56dc79265f99e175040e104e7ac
pkgname = perl-xml-compile-wsdl11
-
diff --git a/PKGBUILD b/PKGBUILD
index ffb2d205056b..2f9ad80425ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
# Generator : CPANPLUS::Dist::Arch 1.32
pkgname=perl-xml-compile-wsdl11
-pkgver=3.07
-pkgrel=3
+pkgver=3.08
+pkgrel=1
pkgdesc='Perl package to create SOAP messages defined by WSDL 1.1'
arch=('any')
url='https://metacpan.org/release/XML-Compile-WSDL11'
@@ -13,11 +13,12 @@ depends=(
'perl-xml-compile>=1.48'
'perl-xml-compile-cache>=1.03'
'perl-xml-compile-soap>=3.23'
+ 'perl-xml-compile-tester'
'perl-log-report>=1.05')
checkdepends=('perl-test-deep')
-source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-WSDL11-3.07.tar.gz)
+source=(http://search.cpan.org/CPAN/authors/id/M/MA/MARKOV/XML-Compile-WSDL11-3.08.tar.gz)
options=(!emptydirs)
-md5sums=('2866c7ef1630b76182deaae36879b9f8')
+md5sums=('2ff6f56dc79265f99e175040e104e7ac')
sanitize() {
unset PERL5LIB PERL_MM_OPT PERL_MB_OPT PERL_LOCAL_LIB_ROOT
@@ -25,20 +26,20 @@ sanitize() {
}
build() {
- cd XML-Compile-WSDL11-3.07
+ cd XML-Compile-WSDL11-3.08
sanitize
/usr/bin/perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
- cd XML-Compile-WSDL11-3.07
+ cd XML-Compile-WSDL11-3.08
sanitize
make test
}
package() {
- cd XML-Compile-WSDL11-3.07
+ cd XML-Compile-WSDL11-3.08
sanitize
make install DESTDIR="$pkgdir"
find "$pkgdir" \( -name .packlist -o -name perllocal.pod \) -delete
diff --git a/PKGBUILD.tt b/PKGBUILD.tt
index 6bbb56dc0c03..2a49b22273b8 100644
--- a/PKGBUILD.tt
+++ b/PKGBUILD.tt
@@ -13,6 +13,7 @@ depends=(
'perl-xml-compile>=1.48'
'perl-xml-compile-cache>=1.03'
'perl-xml-compile-soap>=3.23'
+ 'perl-xml-compile-tester'
'perl-log-report>=1.05')
checkdepends=('perl-test-deep')
source=([% source %])