summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d454baa18b0c..9b4b21956745 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = petool-git
pkgdesc = Tool to help rebuild, extend and patch 32-bit Windows applications.
pkgver = 2024.03.14.r7.g869d58e
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/FunkyFr3sh/petool
- arch = any
+ arch = i686
+ arch = x86_64
license = MIT
makedepends = gcc
makedepends = gcc-libs
makedepends = git
makedepends = make
+ depends = lib32-glibc
provides = petool
conflicts = petool
options = !buildflags
diff --git a/PKGBUILD b/PKGBUILD
index 850afcd74ae1..b9d4559ed654 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,22 +4,22 @@
pkgname=petool-git
_pkgname=petool
pkgver=2024.03.14.r7.g869d58e
-pkgrel=1
-pkgdesc="Tool to help rebuild, extend and patch 32-bit Windows applications."
-arch=('any')
+pkgrel=2
+pkgdesc='Tool to help rebuild, extend and patch 32-bit Windows applications.'
+arch=('i686' 'x86_64')
license=('MIT')
url="https://github.com/FunkyFr3sh/petool"
-depends=()
+depends=('lib32-glibc')
makedepends=('gcc' 'gcc-libs' 'git' 'make')
provides=('petool')
conflicts=('petool')
options=('!buildflags')
-source=("$_pkgname::git+${url}#branch=${BRANCH:-master}")
+source=("${_pkgname}::git+${url}#branch=${BRANCH:-master}")
sha512sums=('SKIP')
pkgver() {
- cd "$srcdir/$_pkgname"
+ cd "${srcdir}/${_pkgname}"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
@@ -30,7 +30,8 @@ build() {
package() {
cd "${srcdir}/${_pkgname}"
- install -Dm 755 petool "${pkgdir}/usr/bin/petool"
+ install -Dm 644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm 755 petool "${pkgdir}/usr/bin/petool"
}
# vim:set ft=sh syn=sh ts=4 sw=4 et: