summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4b5882ca7718..e193a6e8facd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pfstools
pkgdesc = Set of command line programs for reading, writing and manipulating high-dynamic range (HDR) images
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = http://pfstools.sourceforge.net/
arch = i686
arch = x86_64
@@ -17,13 +17,13 @@ pkgbase = pfstools
makedepends = opencv
makedepends = freeglut
makedepends = glu
- makedepends = qt4
makedepends = gtkglext
+ makedepends = gtk3
depends = gcc-libs
- optdepends = freeglut: OpenGL image viewer
- optdepends = glu: OpenGL image viewer
- optdepends = qt4: Qt GUI
+ optdepends = freeglut: OpenGL image viewer pfsglview
+ optdepends = glu: OpenGL image viewer pfsglview
optdepends = opencv: pfsalign
+ optdepends = gtk3: pfsalign
optdepends = openexr: OpenEXR support
optdepends = imagemagick: ImageMagick support
optdepends = netpbm: PBM support
diff --git a/PKGBUILD b/PKGBUILD
index 4d2e9c89a54b..e04ccd6a1b59 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Mael Kerbiriou <mael.kerbiriouATfreeDOTfr>
pkgname=pfstools
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Set of command line programs for reading, writing and manipulating high-dynamic range (HDR) images"
arch=('i686' 'x86_64')
url="http://pfstools.sourceforge.net/"
@@ -11,9 +11,8 @@ license=('LGPL2.1')
depends=('gcc-libs')
provides=('pfscalibration' 'pfstmo')
conflicts=('pfscalibration' 'pfstmo')
-optdepends=('freeglut: OpenGL image viewer' 'glu: OpenGL image viewer' \
- 'qt4: Qt GUI' \
- 'opencv: pfsalign' \
+optdepends=('freeglut: OpenGL image viewer pfsglview' 'glu: OpenGL image viewer pfsglview' \
+ 'opencv: pfsalign' 'gtk3: pfsalign' \
'openexr: OpenEXR support' \
'imagemagick: ImageMagick support' \
'netpbm: PBM support' \
@@ -23,7 +22,7 @@ optdepends=('freeglut: OpenGL image viewer' 'glu: OpenGL image viewer' \
makedepends=('cmake' \
'openexr' 'libmagick6' 'libtiff' 'netpbm' \
'gsl' 'fftw' 'libexif' 'opencv'
- 'freeglut' 'glu' 'qt4' 'gtkglext')
+ 'freeglut' 'glu' 'gtkglext' 'gtk3')
options=(!libtool)
source=("http://downloads.sourceforge.net/pfstools/$pkgname-$pkgver.tgz"
"opencv3.patch" "force_imagemagick6.patch")