summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD27
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..990beedcff42
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pg_rum
+ pkgdesc = RUM access method - inverted index with additional information in posting lists
+ pkgver = 1.2.1
+ pkgrel = 1
+ url = https://github.com/postgrespro/rum
+ arch = x86_64
+ license = custom:PostgreSQL
+ depends = postgresql
+ source = https://github.com/postgrespro/rum/archive/1.2.1.tar.gz
+ md5sums = 0190b2184659d171383db2cbcfb54d8b
+
+pkgname = pg_rum
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dfdd58979d9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alexey Kh <aur@devass.club>
+pkgname=pg_rum
+pkgver=1.2.1
+pkgrel=1
+pkgdesc='RUM access method - inverted index with additional information in posting lists'
+arch=('x86_64')
+url='https://github.com/postgrespro/rum'
+license=('custom:PostgreSQL')
+depends=('postgresql')
+source=("$url/archive/$pkgver.tar.gz")
+
+build()
+{
+ cd "rum-$pkgver"
+
+ make USE_PGXS=1
+}
+
+package()
+{
+ cd "rum-$pkgver"
+
+ make USE_PGXS=1 DESTDIR="$pkgdir" install
+}
+
+md5sums=('0190b2184659d171383db2cbcfb54d8b')
+