summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO34
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD70
-rw-r--r--pam_phosh5
4 files changed, 15 insertions, 98 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c5a6a02dc7d..f514d7a75906 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,34 +1,8 @@
pkgbase = phosh-next
- pkgdesc = Merge requests that are lining up to be merged into the phosh's development branch
- pkgver = next.20220923.2142.r0.g804f3759
+ pkgdesc = metapackage - migrate to phosh-git
+ pkgver = 0.0.1
pkgrel = 1
- url = https://source.puri.sm/Librem5/phosh-next
- arch = x86_64
- arch = aarch64
- arch = armv7h
- license = GPL3
- makedepends = meson
- makedepends = git
- makedepends = wayland-protocols
- depends = gtk3
- depends = libhandy>=1.1.90
- depends = gnome-desktop
- depends = gnome-session
- depends = upower
- depends = libpulse
- depends = gcr
- depends = feedbackd
- depends = libnm
- depends = evolution-data-server
- depends = phoc-embedded-wlroots>=0.21.0
- depends = gnome-shell
- depends = callaudiod
- depends = polkit
- provides = phosh
- conflicts = phosh
- source = git+https://source.puri.sm/Librem5/phosh-next.git
- source = pam_phosh
- sha256sums = SKIP
- sha256sums = b7793f80c533e84ad8adfe8bb46c69f107575e724aa9b53b41f370baa37e4fd5
+ arch = any
pkgname = phosh-next
+ depends = phosh-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 5ec14e75e6d8..0b2e85eee8c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,68 +1,12 @@
-# Maintainer: Thomas Booker <tw.booker@outlook.com>
-# Contributor: Philip Goto <philip.goto@gmail.com>
+# Maintainer:
-pkgname=phosh-next
-pkgver=next.20220923.2142.r0.g804f3759
+_newpkg='phosh-git'
+pkgname='phosh-next'
+pkgver=0.0.1
pkgrel=1
-pkgdesc="Merge requests that are lining up to be merged into the phosh's development branch"
-arch=(x86_64 aarch64 armv7h)
-url='https://source.puri.sm/Librem5/phosh-next'
-license=(GPL3)
-depends=(
- gtk3
- 'libhandy>=1.1.90'
- gnome-desktop
- gnome-session
- upower
- libpulse
- gcr
- feedbackd
- libnm
- evolution-data-server
- # Replace this with phoc once it works.
- #'phoc>=0.21.0'
- 'phoc-embedded-wlroots>=0.21.0'
- gnome-shell
- callaudiod
- polkit
-)
-makedepends=(
- meson
- git
- wayland-protocols
-)
-provides=(phosh)
-conflicts=(phosh)
-source=(
- "git+${url}.git"
- "pam_phosh"
-)
-sha256sums=(
- 'SKIP'
- 'b7793f80c533e84ad8adfe8bb46c69f107575e724aa9b53b41f370baa37e4fd5'
-)
-
-pkgver() {
- cd phosh-next
- git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
-}
-
-prepare() {
- cd phosh-next
-
- git submodule init
- git submodule update
-}
-
-build() {
- # If we don't set `libexecdir` then meson will try and place the phosh bin in /lib/phosh and collide with the dir so we put it in /lib/phosh/phosh
- arch-meson --libexecdir="/usr/lib/phosh" -D tests=false -D systemd=true phosh-next _build
- meson compile -C _build
-}
+pkgdesc="metapackage - migrate to $_newpkg"
+arch=('any')
package() {
- DESTDIR="${pkgdir}" meson install -C _build
-
- install -Dm644 "$srcdir"/pam_phosh \
- "$pkgdir"/etc/pam.d/phosh
+ depends=("$_newpkg")
}
diff --git a/pam_phosh b/pam_phosh
deleted file mode 100644
index 0580d9841cef..000000000000
--- a/pam_phosh
+++ /dev/null
@@ -1,5 +0,0 @@
-#%PAM-1.0
-
-auth include system-local-login
-account include system-local-login
-session include system-local-login