aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore5
-rw-r--r--Dockerfile10
-rw-r--r--LICENSE21
-rw-r--r--PKGBUILD31
-rw-r--r--README.md27
-rw-r--r--fig.yml4
-rw-r--r--php-imagick.install13
8 files changed, 128 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1b7525bb85ba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = php-imagick
+ pkgdesc = PHP extension for IMagick
+ pkgver = 3.1.2
+ pkgrel = 4
+ url = http://pecl.php.net/package/imagick
+ install = php-imagick.install
+ arch = i686
+ arch = x86_64
+ license = PHP
+ depends = php>=5.1.3
+ depends = imagemagick>=6.2.4
+ backup = etc/php/conf.d/imagick.ini
+ source = http://pecl.php.net/get/imagick-3.1.2.tgz
+ md5sums = f2fd71b026debe056e0ec8d76c2ffe94
+
+pkgname = php-imagick
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8b6de3af5215
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/imagick-*.tgz
+/php-imagick-*.pkg.tar.xz
+/php-imagick-*.src.tar.gz
+/pkg/
+/src/
diff --git a/Dockerfile b/Dockerfile
new file mode 100644
index 000000000000..ab317a7882d1
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,10 @@
+FROM nubs/arch-build
+
+MAINTAINER Spencer Rinehart <anubis@overthemonkey.com>
+
+USER root
+
+RUN pacman --sync --refresh --noconfirm --noprogressbar --quiet
+RUN pacman --sync --noconfirm --noprogressbar --quiet php imagemagick
+
+USER build
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..8fb49f589d7c
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Spencer Rinehart
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE. \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9606f7a57301
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Contributor: Spencer Rinehart <anubis@overthemonkey.com>
+
+pkgname=php-imagick
+_extname=imagick
+pkgver=3.1.2
+pkgrel=4
+pkgdesc="PHP extension for IMagick"
+arch=('i686' 'x86_64')
+url="http://pecl.php.net/package/${_extname}"
+license=('PHP')
+depends=('php>=5.1.3' 'imagemagick>=6.2.4')
+backup=("etc/php/conf.d/${_extname}.ini")
+install="php-${_extname}.install"
+source=("http://pecl.php.net/get/${_extname}-${pkgver}.tgz")
+md5sums=('f2fd71b026debe056e0ec8d76c2ffe94')
+
+build() {
+ cd "${_extname}-${pkgver}"
+
+ phpize
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${_extname}-${pkgver}"
+
+ make INSTALL_ROOT="${pkgdir}" install
+ echo "extension=${_extname}.so" > "${_extname}.ini"
+ install -D -m644 "${_extname}.ini" "${pkgdir}/etc/php/conf.d/${_extname}.ini"
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..784cbb4691d7
--- /dev/null
+++ b/README.md
@@ -0,0 +1,27 @@
+# php-imagick-aur
+An [AUR] package build for PHP's [imagick] extension.
+
+## Building
+You can of course build this package using [makepkg], but the recommended way
+of building this package is using [Docker]. This can be done like so:
+
+```bash
+docker build --tag php-imagick-aur .
+docker run --rm --volume "$(pwd):/package" php-imagick-aur
+```
+
+Alternatively, using [Fig]:
+
+```bash
+fig run build
+```
+
+This will start create a docker image tagged as php-imagick-aur and build the
+package inside the container. As a result you should get the built package in
+your current directory.
+
+[AUR]: https://aur.archlinux.org/
+[imagick]: http://pecl.php.net/package/imagick
+[makepkg]: https://wiki.archlinux.org/index.php/Makepkg
+[Docker]: https://www.docker.com/
+[Fig]: http://www.fig.sh/
diff --git a/fig.yml b/fig.yml
new file mode 100644
index 000000000000..b11c60fa7962
--- /dev/null
+++ b/fig.yml
@@ -0,0 +1,4 @@
+build:
+ build: .
+ volumes:
+ - ".:/package"
diff --git a/php-imagick.install b/php-imagick.install
new file mode 100644
index 000000000000..a6674ee4e849
--- /dev/null
+++ b/php-imagick.install
@@ -0,0 +1,13 @@
+post_install() {
+ echo '
+ ==> PHP extension
+
+ A config file was stored under /etc/php/conf.d/ with the extension enabled.
+ '
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+# vim:set ts=2 sw=2 et: