summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
-rw-r--r--kolabformat.ini1
-rw-r--r--php-kolabformat.install10
4 files changed, 24 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a644c1acd269..034a9db9f202 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,25 +1,26 @@
-# Generated by mksrcinfo v8
-# Thu Jul 27 19:59:46 UTC 2017
pkgbase = php-kolabformat
pkgdesc = PHP bindings for Kolab XML Format Schema Definitions Library
pkgver = 1.1.6
- pkgrel = 3
+ pkgrel = 4
url = http://www.kolab.org
+ install = php-kolabformat.install
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = boost
makedepends = xsd
- makedepends = qt4
+ makedepends = qt5-base
makedepends = swig>=3.0.11
depends = libkolabxml
depends = php
options = !strip
source = https://mirror.kolabenterprise.com/pub/releases/libkolabxml-1.1.6.tar.gz
source = php7.patch
+ source = kolabformat.ini
sha256sums = e48d7f5de1860a381da27981f6c70de1c9f38c4cd536bc6558b6529ce95f0677
sha256sums = 59b99b529ffecf01566ff10a8f33a087b34330cc95d92d86c45ad105c7144f98
+ sha256sums = 4ce9a46b45d87add01ad132fb602508e4892dd4f684fe5d95c6c7172b008641b
pkgname = php-kolabformat
diff --git a/PKGBUILD b/PKGBUILD
index e3343d4b59d9..4214d94ae256 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,21 @@
-# Maintainer: Javier Torres <javitonino [at] gmail [dot] com>
+# Maintainer: Timo Sarawinskis <timo [at] it-kraut [dot] net>
pkgname=php-kolabformat
pkgver=1.1.6
-pkgrel=3
+pkgrel=4
pkgdesc='PHP bindings for Kolab XML Format Schema Definitions Library'
url='http://www.kolab.org'
arch=('i686' 'x86_64')
license=('GPL')
depends=('libkolabxml' 'php')
-makedepends=('cmake' 'boost' 'xsd' 'qt4' 'swig>=3.0.11')
+makedepends=('cmake' 'boost' 'xsd' 'qt5-base' 'swig>=3.0.11')
source=("https://mirror.kolabenterprise.com/pub/releases/libkolabxml-${pkgver}.tar.gz"
- "php7.patch")
+ "php7.patch" "kolabformat.ini")
sha256sums=('e48d7f5de1860a381da27981f6c70de1c9f38c4cd536bc6558b6529ce95f0677'
- '59b99b529ffecf01566ff10a8f33a087b34330cc95d92d86c45ad105c7144f98')
+ '59b99b529ffecf01566ff10a8f33a087b34330cc95d92d86c45ad105c7144f98'
+ '4ce9a46b45d87add01ad132fb602508e4892dd4f684fe5d95c6c7172b008641b')
options=('!strip')
+install=php-kolabformat.install
prepare() {
cd "${srcdir}/libkolabxml-${pkgver}"
patch -p1 < "${srcdir}/php7.patch"
@@ -37,4 +39,5 @@ package() {
# make DESTDIR="${pkgdir}" install
install -Dm755 "kolabformat.so" "${pkgdir}/usr/lib/php/modules/kolabformat.so"
install -Dm644 "kolabformat.php" "${pkgdir}/usr/share/php/kolabformat.php"
+ install -Dm644 "${srcdir}/kolabformat.ini" "${pkgdir}/etc/php/conf.d/kolabformat.ini"
}
diff --git a/kolabformat.ini b/kolabformat.ini
new file mode 100644
index 000000000000..2d4941d128c7
--- /dev/null
+++ b/kolabformat.ini
@@ -0,0 +1 @@
+;extension=kolabformat
diff --git a/php-kolabformat.install b/php-kolabformat.install
new file mode 100644
index 000000000000..fa56baf81074
--- /dev/null
+++ b/php-kolabformat.install
@@ -0,0 +1,10 @@
+post_install() {
+ echo '
+ ==> PHP extension
+
+ A config file was stored under /etc/php/conf.d/. In order to use this
+ extension make sure to uncomment it from its config file.
+ '
+}
+
+# vim:set ts=2 sw=2 et: