summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD54
3 files changed, 45 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b02d44ab128..39fa9259a32b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,16 @@
pkgbase = php-runkit
- pkgdesc = Runkit is set of tools which allowes to do what Reflection does not allow. Usefull for unit tests.
- pkgver = git
+ pkgdesc = Tools to allow what Reflection does not. Useful for unit tests.
+ pkgver = 4.0.0a6.r1.g8ffec37
pkgrel = 1
- url = https://github.com/zenovich/runkit
+ url = https://github.com/runkit7/runkit7
arch = x86_64
arch = i686
license = PHP
makedepends = php
depends = php
- source = git+https://github.com/zenovich/runkit.git
- source = https://github.com/zenovich/runkit/pull/73.diff
- md5sums = SKIP
- md5sums = 768c220680f414b1b3858f0d856e6a40
+ provides = php-runkit
+ conflicts = php-runkit
+ source = php-runkit::git+https://github.com/runkit7/runkit7
+ sha256sums = SKIP
pkgname = php-runkit
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..018a3de08144
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 8d6992b09715..181758eba0aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,47 @@
-# Maintainer: Alexey Manukhin <axxapy@gmail.com>
+# Maintainer:
+# Contributor: Alexey Manukhin <axxapy@gmail.com>
-pkgname=php-runkit
-pkgdesc='Runkit is set of tools which allowes to do what Reflection does not allow. Usefull for unit tests.'
-pkgver=git
+_pkgname="php-runkit"
+pkgname="$_pkgname"
+pkgdesc='Tools to allow what Reflection does not. Useful for unit tests.'
+pkgver=4.0.0a6.r1.g8ffec37
pkgrel=1
arch=('x86_64' 'i686')
license=('PHP')
-url=https://github.com/zenovich/runkit
+url="https://github.com/runkit7/runkit7"
-makedepends=('php')
-source=("git+https://github.com/zenovich/runkit.git" "https://github.com/zenovich/runkit/pull/73.diff")
-md5sums=('SKIP' '768c220680f414b1b3858f0d856e6a40')
depends=('php')
+makedepends=('php')
+
+provides=("$_pkgname")
+conflicts=(${provides[@]})
+
+source=(
+ "$_pkgname"::"git+$url"
+)
+sha256sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
build() {
- cd ${srcdir}/runkit || return 1
- patch -p1 < $startdir/73.diff
- phpize || return 1
- ./configure ${peclconfig}|| return 1
- make || return 1
+ cd "$srcdir/$_pkgname"
+ phpize
+ ./configure
+ make
}
-package_php-runkit() {
- install -d -m755 ${pkgdir}/usr/lib/php/modules/
- install -m644 ${srcdir}/runkit/modules/runkit.so ${pkgdir}/usr/lib/php/modules//runkit.so
-
- echo 'extension=runkit.so' > ${startdir}/runkit.ini || return 1
- echo 'runkit.internal_override=1' >> ${startdir}/runkit.ini || return 1
- install -D -m 644 $startdir/runkit.ini ${pkgdir}/etc/php/conf.d/runkit.ini || return 1
+package() {
+ cd "$srcdir/$_pkgname"
+ install -vDm0644 "$srcdir/$_pkgname/modules/runkit7.so" "$pkgdir/usr/lib/php/modules/runkit7.so"
+
+ echo 'extension=runkit7.so' > "$srcdir/runkit7.ini"
+ echo 'runkit7.internal_override=1' >> "$srcdir/runkit7.ini"
+ install -vDm0644 "$srcdir/runkit7.ini" -t "$pkgdir}/etc/php/conf.d"
}