summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD13
-rw-r--r--constant_016.phpt.patch10
-rw-r--r--php-fpm.patch4
-rw-r--r--php.ini.patch7
4 files changed, 22 insertions, 12 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f388890d0e17..1d6ef56e3584 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ pkgname=("${pkgbase}"
"${pkgbase}-tidy"
"${pkgbase}-xsl")
-pkgver=8.1.7
+pkgver=8.2.0
pkgrel=1
arch=('x86_64')
license=('PHP')
@@ -36,16 +36,14 @@ checkdepends=('procps-ng')
options=(debug)
source=("https://php.net/distributions/${_pkgbase}-${pkgver}.tar.xz"{,.asc}
'apache.patch' 'apache.conf' 'php-fpm.patch' 'php-fpm.tmpfiles' 'php.ini.patch')
-sha256sums=('f042322f1b5a9f7c2decb84b7086ef676896c2f7178739b9672afafa964ed0e5'
+sha256sums=('6ea4c2dfb532950fd712aa2a08c1412a6a81cd1334dd0b0bf88a8e44c2b3a943'
'SKIP'
'c24122c0a742d3f153d52076137e737da0191584dab178bafed547b3bf2a28e8'
'aee6ee73d1b3cf161069c355e8472a2ceda0886e98bf6a69d57c1dcf6b09ab17'
- 'aa55fa4fc5c2b2493065bbd00cfe3c97a1b22b3dc7d34f8fd303de18cafe844f'
+ '69beb06f8eed1b9d61f1f2ad71b8d1026e0389b7f4cbedbf540ab84427c86d95'
'640dba0d960bfeaae9ad38d2826d3f6b5d6c175a4d3e16664eefff29141faad5'
- 'b3b3385f1c36e272671c7db238b2a69896e11a82db90dafd74964f2eabbfa2f2')
-validpgpkeys=('F1F692238FBC1666E5A5CCD4199F9DFEF6FFBAFD',
- '528995BFEDFBA7191D46839EF9BA0ADA31CBD89E'
- '39B641343D8C104B2B146DC3F9C39DC0B9698544')
+ '47d36703914f9e26c33e06fab8aa66af918af8f06f4168db7d8c6b8104abc0d3')
+validpgpkeys=('E60913E4DF209907D8E30D96659A97C9CF2A795A')
_interpreter=${pkgver%.*}
prepare() {
@@ -54,6 +52,7 @@ prepare() {
patch -p0 -i "${srcdir}/apache.patch"
patch -p0 -i "${srcdir}/php-fpm.patch"
patch -p0 -i "${srcdir}/php.ini.patch"
+ patch -p0 -i "${srcdir}/constant_016.phpt.patch"
autoconf
# Disable failing tests
diff --git a/constant_016.phpt.patch b/constant_016.phpt.patch
new file mode 100644
index 000000000000..a8abb31b91d5
--- /dev/null
+++ b/constant_016.phpt.patch
@@ -0,0 +1,10 @@
+--- Zend/tests/traits/constant_016.phpt.orig
++++ Zend/tests/traits/constant_016.phpt
+@@ -2,6 +2,8 @@
+ Compatibility of values of same name trait constants is checked after their constant expressions are evaluated
+ --ENV--
+ ENSURE_CONSTANT_IS_DEFINED_AT_RUNTIME=1
++--INI--
++variables_order=EGPCS
+ --FILE--
+ <?php
diff --git a/php-fpm.patch b/php-fpm.patch
index b62fff1158cf..d42ed9083d8d 100644
--- a/php-fpm.patch
+++ b/php-fpm.patch
@@ -40,7 +40,7 @@
+listen = /run/php-fpm/php-fpm.sock
; Set listen(2) backlog.
- ; Default Value: 511 (-1 on FreeBSD and OpenBSD)
+ ; Default Value: 511 (-1 on Linux, FreeBSD and OpenBSD)
@@ -45,8 +45,8 @@
; and group can be specified either by name or by their numeric IDs.
; Default Values: user and group are set as the running user
@@ -52,7 +52,7 @@
;listen.mode = 0660
; When POSIX Access Control Lists are supported you can set them using
; these options, value is a comma separated list of user/group names.
-@@ -395,7 +395,7 @@
+@@ -416,7 +416,7 @@
; Chdir to this directory at the start.
; Note: relative path can be used.
; Default Value: current directory or / when chroot
diff --git a/php.ini.patch b/php.ini.patch
index 5c60b6e5920c..8b8153cdc1ed 100644
--- a/php.ini.patch
+++ b/php.ini.patch
@@ -9,14 +9,14 @@
; On windows:
;extension_dir = "ext"
-@@ -908,51 +908,44 @@
+@@ -908,52 +908,44 @@
; deprecated in a future PHP major version. So, when it is possible, please
; move to the new ('extension=<ext>) syntax.
;
-; Notes for Windows environments :
-;
--; - Many DLL files are located in the extensions/ (PHP 4) or ext/ (PHP 5+)
--; extension folders as well as the separate PECL DLL download (PHP 5+).
+-; - Many DLL files are located in the ext/
+-; extension folders as well as the separate PECL DLL download.
-; Be sure to appropriately set the extension_dir directive.
-;
+;extension=bcmath
@@ -70,6 +70,7 @@
+;extension=sysvshm
;extension=tidy
;extension=xsl
+-;extension=zip
-
-;zend_extension=opcache
+extension=zip