aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO14
-rwxr-xr-x.gitignore5
-rwxr-xr-xDockerfile12
-rwxr-xr-xLICENSE21
-rwxr-xr-xPKGBUILD32
-rwxr-xr-xREADME.md32
-rwxr-xr-xdocker-compose.yml4
7 files changed, 120 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..92fa93aaff60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = php74-oci8
+ pkgdesc = PHP extension for OCI8
+ pkgver = 2.2.0
+ pkgrel = 1
+ url = https://pecl.php.net/package/oci8
+ arch = x86_64
+ license = PHP
+ depends = php74>=7.4.0
+ depends = oracle-instantclient-sdk
+ backup = etc/php/conf.d/oci8.ini
+ source = https://pecl.php.net/get/oci8-2.2.0.tgz
+ md5sums = 678d2a647881cd8e5b458c669dcce215
+
+pkgname = php74-oci8
diff --git a/.gitignore b/.gitignore
new file mode 100755
index 000000000000..660688b29478
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+/oci8-*.tgz
+/php-oci8-*.pkg.tar.xz
+/php-oci8-*.src.tar.gz
+/pkg/
+/src/
diff --git a/Dockerfile b/Dockerfile
new file mode 100755
index 000000000000..44aa7a2a3529
--- /dev/null
+++ b/Dockerfile
@@ -0,0 +1,12 @@
+FROM nubs/arch-build
+
+MAINTAINER Spencer Rinehart <anubis@overthemonkey.com>
+
+USER root
+
+RUN bash -c 'echo -e "[oracle]\nSigLevel = Optional TrustAll\nServer = http://linux.shikadi.net/arch/\$repo/\$arch/" >>/etc/pacman.conf'
+
+RUN pacman --sync --refresh --noconfirm --noprogressbar --quiet
+RUN pacman --sync --noconfirm --noprogressbar --quiet php oracle-instantclient-sdk
+
+USER build
diff --git a/LICENSE b/LICENSE
new file mode 100755
index 000000000000..4efa9e99f6ce
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,21 @@
+The MIT License (MIT)
+
+Copyright (c) 2014-2016 Spencer Rinehart
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in all
+copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..69c95bc84840
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Spencer Rinehart <anubis@overthemonkey.com>
+# Contributor: Marcel Pfeiffer <m.pfeiffer@strucnamics.de>
+# Contributor: Denis Sobchuk <dnsobchuk@yandex.ru>
+
+pkgname=php74-oci8
+_extname=oci8
+pkgver=2.2.0
+pkgrel=1
+pkgdesc="PHP extension for OCI8"
+arch=('x86_64')
+url="https://pecl.php.net/package/${_extname}"
+license=('PHP')
+depends=('php74>=7.4.0' 'oracle-instantclient-sdk')
+backup=("etc/php/conf.d/${_extname}.ini")
+source=("https://pecl.php.net/get/${_extname}-${pkgver}.tgz")
+md5sums=('678d2a647881cd8e5b458c669dcce215')
+
+build() {
+ cd "${_extname}-${pkgver}"
+
+ phpize74
+ ./configure --prefix=/usr --with-oci8=instantclient,/usr/lib
+ make
+}
+
+package() {
+ cd "${_extname}-${pkgver}"
+
+ make INSTALL_ROOT="${pkgdir}" install
+ echo "extension=${_extname}.so" > "${_extname}.ini"
+ install -D -m644 "${_extname}.ini" "${pkgdir}/etc/php74/conf.d/${_extname}.ini"
+}
diff --git a/README.md b/README.md
new file mode 100755
index 000000000000..eab0a00e17d1
--- /dev/null
+++ b/README.md
@@ -0,0 +1,32 @@
+# php-oci8-aur
+An [AUR] package build for PHP's [OCI8] extension.
+
+## Building
+You can of course build this package using [makepkg], but the recommended way
+of building this package is using [Docker]. This can be done like so:
+
+```bash
+docker build --tag php-oci8-aur .
+docker run --rm --volume "$(pwd):/package" php-oci8-aur
+```
+
+Alternatively, using [Docker Compose]:
+
+```bash
+docker-compose run build
+```
+
+This will start create a docker image tagged as php-oci8-aur and build the
+package inside the container. As a result you should get the built package in
+your current directory.
+
+## License
+php-oci8-aur is licensed under the MIT license. See [LICENSE] for the full
+license text.
+
+[AUR]: https://aur.archlinux.org/
+[oci8]: https://pecl.php.net/package/oci8
+[makepkg]: https://wiki.archlinux.org/index.php/Makepkg
+[Docker]: https://www.docker.com/
+[Docker Compose]: https://docs.docker.com/compose/
+[LICENSE]: https://github.com/nubs/php-oci8-aur/blob/master/LICENSE
diff --git a/docker-compose.yml b/docker-compose.yml
new file mode 100755
index 000000000000..b11c60fa7962
--- /dev/null
+++ b/docker-compose.yml
@@ -0,0 +1,4 @@
+build:
+ build: .
+ volumes:
+ - ".:/package"