summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD31
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df0336247513
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = php83-xdebug
+ pkgdesc = Xdebug is an extension for PHP to assist with debugging and development for php83
+ pkgver = 3.3.1
+ pkgrel = 1
+ url = https://xdebug.org/
+ arch = x86_64
+ license = Xdebug
+ depends = php83
+ backup = etc/php83/conf.d/xdebug.ini
+ source = http://pecl.php.net/get/xdebug-3.3.1.tgz
+ sha256sums = 4eb4ee270bbcc5f14195c38f6ee58580e007cf4886ce32e11430318ab5bc2315
+
+pkgname = php83-xdebug
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..1cbf1cb70176
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+php71*
+php80*
+pkg/*
+src/*
+xdebug/*
+*.tar.*
+*.t?z \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cba755372edf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+pkgname=php83-xdebug
+_phpbase=83
+_extname=xdebug
+pkgver=3.3.1
+pkgrel=1
+pkgdesc="Xdebug is an extension for PHP to assist with debugging and development for php${_phpbase}"
+arch=("x86_64")
+url="https://xdebug.org/"
+license=('Xdebug')
+depends=("php${_phpbase}")
+makedepends=()
+source=("http://pecl.php.net/get/$_extname-$pkgver.tgz")
+backup=("etc/php${_phpbase}/conf.d/$_extname.ini")
+
+build() {
+ cd "$srcdir/$_extname-$pkgver"
+ phpize${_phpbase}
+ ./configure --with-php-config=php-config${_phpbase}
+ make
+}
+
+package() {
+ cd "$srcdir/$_extname-$pkgver"
+ install -m0755 -d "$pkgdir/etc/php${_phpbase}/conf.d/"
+ install -m0644 -D "LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+ echo ";zend_extension=$_extname.so" > "$pkgdir/etc/php${_phpbase}/conf.d/$_extname.ini"
+ chmod 0644 "$pkgdir/etc/php${_phpbase}/conf.d/$_extname.ini"
+ install -m0755 -D ".libs/$_extname.so" "$pkgdir$(php-config${_phpbase} --extension-dir)/$_extname.so"
+}
+
+sha256sums=('4eb4ee270bbcc5f14195c38f6ee58580e007cf4886ce32e11430318ab5bc2315')