summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD31
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..950f191e363b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pico-tts
+ pkgdesc = lib and unix binary for text-to-speech engine from Android
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/Iiridayn/pico-tts
+ arch = x86_64
+ license = MIT
+ makedepends = binutils
+ makedepends = git
+ provides = libsvoxpico.so
+
+pkgname = pico-tts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..257f6827965b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Michael Clark <iiridayn@gmail.com>
+pkgname=pico-tts
+pkgver=0.1
+pkgrel=1
+pkgdesc="lib and unix binary for text-to-speech engine from Android"
+arch=('x86_64')
+url="https://github.com/Iiridayn/pico-tts"
+license=('MIT')
+makedepends=('binutils' 'git')
+provides=('libsvoxpico.so')
+
+prepare() {
+ if [ -d "$pkgname" ]; then
+ git -C "$pkgname" fetch
+ else
+ git clone --recurse-submodules "https://github.com/Iiridayn/pico-tts.git"
+ fi
+ cd "$pkgname"
+ git checkout tags/"$pkgver"
+ git submodule update
+}
+
+build() {
+ cd "$pkgname"
+ make
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}