summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD32
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..af2b4eda656c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = pipe-rename-git
+ pkgdesc = Rename your files using your favorite text editor
+ pkgver = 1.1.6.r1.gb734616
+ pkgrel = 1
+ url = https://github.com/marcusbuffett/pipe-rename
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = cargo
+ depends = gcc-libs
+ source = pipe-rename-git::git+https://github.com/marcusbuffett/pipe-rename.git
+ sha256sums = SKIP
+ b2sums = SKIP
+
+pkgname = pipe-rename-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..33da6233a203
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: KokaKiwi <kokakiwi+aur at kokakiwi dot net>
+
+pkgname=pipe-rename-git
+pkgver=1.1.6.r1.gb734616
+pkgrel=1
+pkgdesc='Rename your files using your favorite text editor'
+url='https://github.com/marcusbuffett/pipe-rename'
+arch=('x86_64' 'i686')
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('git' 'cargo')
+source=("${pkgname}::git+https://github.com/marcusbuffett/pipe-rename.git")
+sha256sums=('SKIP')
+b2sums=('SKIP')
+
+pkgver() {
+ cd "${pkgname}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${pkgname}"
+
+ cargo build --release --locked --all-features --target-dir=target
+}
+
+package() {
+ cd "${pkgname}"
+
+ install -Dm0755 target/release/renamer "${pkgdir}/usr/bin/pipe-rename"
+}