summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4ca6ab088151..4121f6aaa12a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = pkg2zip-fork
pkgdesc = This is for lusid1's fork, recomended by NoPayStation. Decrypts PlayStation Vita pkg file and packages to zip archive
- pkgver = 2.2
+ pkgver = 2.3
pkgrel = 2
url = https://github.com/lusid1/pkg2zip
arch = i686
arch = x86_64
license = custom:unlicense
- source = https://github.com/lusid1/pkg2zip/archive/2.2.tar.gz
- sha256sums = f2a347448324a027edf02cf80dee695394bfcb73298203fd355f0e33e014989b
+ source = https://github.com/lusid1/pkg2zip/archive/2.3.tar.gz
+ sha256sums = SKIP
pkgname = pkg2zip-fork
-
diff --git a/PKGBUILD b/PKGBUILD
index 328b72297acb..8531fab8001c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,23 @@
# Maintainer: evertonstz
pkgname=pkg2zip-fork
-pkgver=2.2
+pkgver=2.3
pkgrel=2
pkgdesc="This is for lusid1's fork, recomended by NoPayStation. Decrypts PlayStation Vita pkg file and packages to zip archive"
url='https://github.com/lusid1/pkg2zip'
arch=('i686' 'x86_64')
license=('custom:unlicense')
source=("https://github.com/lusid1/pkg2zip/archive/${pkgver}.tar.gz")
-sha256sums=('f2a347448324a027edf02cf80dee695394bfcb73298203fd355f0e33e014989b')
+sha256sums=('SKIP')
-package() {
+build() {
+cd "${srcdir}"/"pkg2zip-${pkgver}"
+make CFLAGS="-DNDEBUG -O2 -Wno-format-truncation"
+}
+package() {
cd "${srcdir}"/"pkg2zip-${pkgver}"
- make CFLAGS="-DNDEBUG -O2 -Wno-format-truncation"
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/pkg2zip/LICENSE
- install -Dm755 pkg2zip "${pkgdir}"/usr/bin/pkg2zip
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/pkg2zip/LICENSE"
+ install -Dm755 pkg2zip "${pkgdir}/usr/bin/pkg2zip"
}