summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD10
-rwxr-xr-xpkgdistcache-client4
-rwxr-xr-xpkgdistcache-daemon4
-rw-r--r--pkgdistcached.service3
5 files changed, 18 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 946b8e874143..a49722449da0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Mar 20 02:20:50 UTC 2018
pkgbase = pkgdistcache
pkgdesc = A distributed local-network cache for pacman packages
- pkgver = 0.5.0
+ pkgver = 0.5.1
pkgrel = 3
url = http://venator.ath.cx/dw/doku.php?id=linux:pkgdistcache
install = pkgdistcache.install
@@ -14,16 +12,15 @@ pkgbase = pkgdistcache
depends = python-gobject
depends = curl
depends = python-requests
- depends = python-xdg
+ depends = python-pyxdg
backup = etc/pkgdistcache.conf
source = pkgdistcache-client
source = pkgdistcache-daemon
source = pkgdistcache.conf
source = pkgdistcached.service
- sha256sums = eac5e8c4afebdbb3b93d9d50d10abdaa3cdbd9da796d969f2cd9db2064a69d8d
- sha256sums = 10379b95265e7aa3c6334197ef255327281e35b958c3c062ae893dd3a646a66e
+ sha256sums = a84a9e36471090bf584721747baf2b2b49bacf1c32d8759c3d286bbb331a7f60
+ sha256sums = 6443de9081b7cf350cc261ac9d761bcdf17d01218f762ab85d747ea7eaf90a1d
sha256sums = 25106b1e2ed50d04a684f4d356f3d5a34c815fe77af486c863a292dc7643105f
- sha256sums = b98bccb089bc0025b0f9b4b949b691e5564b0e40778a263a5bb6ffa5f01d04a2
+ sha256sums = 40cb9b08b94960c28423d17447aca8635e6b4038172b6b9a0da6f438e1bcefac
pkgname = pkgdistcache
-
diff --git a/PKGBUILD b/PKGBUILD
index 7419c020db56..32d55bd2f345 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=pkgdistcache
-pkgver=0.5.0
+pkgver=0.5.1
pkgrel=3
pkgdesc='A distributed local-network cache for pacman packages'
arch=('any')
url='http://venator.ath.cx/dw/doku.php?id=linux:pkgdistcache'
license=('GPL')
-depends=('avahi' 'python-dbus' 'dbus-glib' 'python-gobject' 'curl' 'python-requests' 'python-xdg')
+depends=('avahi' 'python-dbus' 'dbus-glib' 'python-gobject' 'curl' 'python-requests' 'python-pyxdg')
backup=('etc/pkgdistcache.conf')
install="${pkgname}.install"
source=('pkgdistcache-client'
'pkgdistcache-daemon'
'pkgdistcache.conf'
'pkgdistcached.service')
-sha256sums=('eac5e8c4afebdbb3b93d9d50d10abdaa3cdbd9da796d969f2cd9db2064a69d8d'
- '10379b95265e7aa3c6334197ef255327281e35b958c3c062ae893dd3a646a66e'
+sha256sums=('a84a9e36471090bf584721747baf2b2b49bacf1c32d8759c3d286bbb331a7f60'
+ '6443de9081b7cf350cc261ac9d761bcdf17d01218f762ab85d747ea7eaf90a1d'
'25106b1e2ed50d04a684f4d356f3d5a34c815fe77af486c863a292dc7643105f'
- 'b98bccb089bc0025b0f9b4b949b691e5564b0e40778a263a5bb6ffa5f01d04a2')
+ '40cb9b08b94960c28423d17447aca8635e6b4038172b6b9a0da6f438e1bcefac')
package() {
install -d "${pkgdir}/usr/bin/"
diff --git a/pkgdistcache-client b/pkgdistcache-client
index dec92223daa2..8bc7d8ad6680 100755
--- a/pkgdistcache-client
+++ b/pkgdistcache-client
@@ -17,11 +17,13 @@ import time
import avahi
import dbus
-import dbus.glib
+from dbus.mainloop.glib import DBusGMainLoop
import requests
import xdg.BaseDirectory
from gi.repository import GLib
+DBusGMainLoop(set_as_default=True)
+
colors = {
'none': '\033[0m',
'black': '\033[0;30m', 'bold_black': '\033[1;30m',
diff --git a/pkgdistcache-daemon b/pkgdistcache-daemon
index 5d5b7899d8e8..6b911e174ca4 100755
--- a/pkgdistcache-daemon
+++ b/pkgdistcache-daemon
@@ -14,7 +14,9 @@ import sys
import avahi
import dbus
-import dbus.glib
+from dbus.mainloop.glib import DBusGMainLoop
+
+DBusGMainLoop(set_as_default=True)
avahi_service = None
diff --git a/pkgdistcached.service b/pkgdistcached.service
index db1303fa3c7a..f5e58204744b 100644
--- a/pkgdistcached.service
+++ b/pkgdistcached.service
@@ -5,7 +5,8 @@ After=avahi-daemon.service
[Service]
ExecStart=/usr/lib/pkgdistcache/pkgdistcache-daemon
-DynamicUser=yes
+User=nobody
+Group=nobody
NoNewPrivileges=yes
PrivateTmp=yes
PrivateDevices=yes