summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD4
-rwxr-xr-xpkgdistcache-client2
3 files changed, 7 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4d03ad61263..1bbfaf8e5b8a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Dec 27 15:40:49 UTC 2017
+# Wed Dec 27 23:37:36 UTC 2017
pkgbase = pkgdistcache
pkgdesc = A distributed local-network cache for pacman packages
- pkgver = 0.4.4
+ pkgver = 0.4.5
pkgrel = 1
url = http://venator.ath.cx/dw/doku.php?id=linux:pkgdistcache
install = pkgdistcache.install
@@ -13,11 +13,12 @@ pkgbase = pkgdistcache
depends = dbus-glib
depends = python-gobject
depends = curl
+ depends = python-requests
source = pkgdistcache-client
source = pkgdistcache-daemon
source = pkgdistcache.conf
source = pkgdistcached.service
- sha256sums = c3549b1a2ab680fba6c2cfc80ffc31010ee20831f40be8b64eee3cfec60965cf
+ sha256sums = 86303871992738372d6ea5d11c3e75a7b894d5ebff1018fdbf213f393fc42be8
sha256sums = 8f298c9f1548b56373038fe69f8568dc77e17a700476594155359df20eb275a4
sha256sums = d77ac418aa651bc622cd91204d6907554c6cdb4bb989e484cc54da32342faa51
sha256sums = 756c0bd1139e296da88937a89ab19e0b5d6c0d5d0f719034d4029b1fe1ea09e9
diff --git a/PKGBUILD b/PKGBUILD
index 8f5b19d632e3..1a42f8215cdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Maintainer: Eric Anderson <ejona86@gmail.com>
pkgname=pkgdistcache
-pkgver=0.4.4
+pkgver=0.4.5
pkgrel=1
pkgdesc='A distributed local-network cache for pacman packages'
arch=('any')
@@ -14,7 +14,7 @@ source=('pkgdistcache-client'
'pkgdistcache-daemon'
'pkgdistcache.conf'
'pkgdistcached.service')
-sha256sums=('612b58f5992a20c241a03c0d205dc92e0f8de10e00ed6a81c99fb0b9fb28ab31'
+sha256sums=('86303871992738372d6ea5d11c3e75a7b894d5ebff1018fdbf213f393fc42be8'
'8f298c9f1548b56373038fe69f8568dc77e17a700476594155359df20eb275a4'
'd77ac418aa651bc622cd91204d6907554c6cdb4bb989e484cc54da32342faa51'
'756c0bd1139e296da88937a89ab19e0b5d6c0d5d0f719034d4029b1fe1ea09e9')
diff --git a/pkgdistcache-client b/pkgdistcache-client
index 8b5d8b7cb46c..7ad821bf7b69 100755
--- a/pkgdistcache-client
+++ b/pkgdistcache-client
@@ -124,7 +124,7 @@ def main(argv):
pkg = os.path.basename(argv[1]) # argv[1] = %u passed by pacman
must_download = True
- if not pkg.endswith('.db.tar.gz'):
+ if not (pkg.endswith('.db') or pkg.endswith('.db.sig')):
# find first /tmp/pkgdistcache.* file modified less than CACHE_FILE_LIFE minutes ago
cmd = 'find /tmp -name "pkgdistcache.*" -mmin -' + str(config['cache_file_life'])
cache_file = runcmd(cmd)['stdout']