summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG21
-rw-r--r--PKGBUILD5
3 files changed, 26 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 31e5d819a135..afb34fadf03d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pkl
pkgdesc = A configuration as code language with rich validation and tooling.
- pkgver = 0.25.2
+ pkgver = 0.25.3
pkgrel = 1
url = https://pkl-lang.org
changelog = CHANGELOG
@@ -8,9 +8,7 @@ pkgbase = pkl
license = Apache
makedepends = jdk-openjdk
makedepends = git
- conflicts = pkl-git
- conflicts = pkl-bin
- source = https://github.com/apple/pkl/archive/refs/tags/0.25.2.tar.gz
- b2sums = 323a0d496591367f8b530811005540fd283c6affa0358c701e5f30ae3b751b6888dcd20f01812918a2558166a26c4948f9f77770733f224e2dd79b99e2c5f4e3
+ source = https://github.com/apple/pkl/archive/refs/tags/0.25.3.tar.gz
+ b2sums = b9a005631315527315d77c79d0801aaba2c687e512a8c1c0dc9891fca48e0e353b4693bd82d44f10f16956d806015da89c86696c791cf3c5fd39c2ca5f3afe22
pkgname = pkl
diff --git a/CHANGELOG b/CHANGELOG
index bc8334fa54d9..57489832b861 100644
--- a/CHANGELOG
+++ b/CHANGELOG
@@ -1,3 +1,24 @@
+Changes in version 0.25.3 (2024-03-26)
+
+ Fixes:
+ - Fixes some issues with generated pkldoc websites (#357, #362)
+ - Fixes a bug where amending a module that defines an abstract class might
+ cause a Java AssertionError (#319)
+ - Fixes a bug where a for/when generator within a lambda declared with new
+ {} syntax might not resolve variables correctly (#297)
+ - Fixes a bug where const and local modifiers are not exported when
+ obtaining a class’s mirror in pkl:reflect (#265).
+
+ Miscellaneous:
+ - Documentation improvements (#93, #106, #143, #205, #214, #224, #257, #270,
+ #282, #283, #299, #337, #340)
+
+ - Build script improvements (#253, #314, #333, #338)
+
+ Changes:
+ Add jpkl to the set of artifacts released to GitHub (#314)
+
+
Changes in version 0.25.2 (2024-02-08)
Fixes:
diff --git a/PKGBUILD b/PKGBUILD
index eaafc92dbaf0..948d4efc231e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,16 @@
# Maintainer: Jiri Pospisil <jiri@jpospisil.com>
pkgname=pkl
-pkgver=0.25.2
+pkgver=0.25.3
pkgrel=1
pkgdesc='A configuration as code language with rich validation and tooling.'
arch=('x86_64')
url='https://pkl-lang.org'
license=('Apache')
-conflicts=('pkl-git' 'pkl-bin')
makedepends=('jdk-openjdk' 'git')
changelog=CHANGELOG
source=("https://github.com/apple/pkl/archive/refs/tags/$pkgver.tar.gz")
-b2sums=('323a0d496591367f8b530811005540fd283c6affa0358c701e5f30ae3b751b6888dcd20f01812918a2558166a26c4948f9f77770733f224e2dd79b99e2c5f4e3')
+b2sums=('b9a005631315527315d77c79d0801aaba2c687e512a8c1c0dc9891fca48e0e353b4693bd82d44f10f16956d806015da89c86696c791cf3c5fd39c2ca5f3afe22')
build() {
cd "$srcdir/pkl-$pkgver"