summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD27
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..67dc3864475f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = plasma-video-wallpaper-git
+ pkgdesc = Allows the use of video wallpaper and lock screen in KDE Plasma
+ pkgver = r13.65a7928
+ pkgrel = 1
+ url = https://github.com/halverneus/org.kde.video
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = plasma-workspace
+ source = git+https://github.com/halverneus/org.kde.video.git
+ sha256sums = SKIP
+
+pkgname = plasma-video-wallpaper-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bc6152969887
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=plasma-video-wallpaper-git
+pkgver=r13.65a7928
+pkgrel=1
+pkgdesc='Allows the use of video wallpaper and lock screen in KDE Plasma'
+arch=('any')
+url='https://github.com/halverneus/org.kde.video'
+license=('GPL')
+depends=('plasma-workspace')
+makedepends=('git')
+source=('git+https://github.com/halverneus/org.kde.video.git')
+sha256sums=('SKIP')
+_gitname='org.kde.video'
+
+pkgver() {
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+package() {
+ mkdir -p "${pkgdir}/usr/share/plasma/wallpapers"
+ cp -rf "${srcdir}/${_gitname}" "${pkgdir}/usr/share/plasma/wallpapers/"
+ rm -rf "${pkgdir}/usr/share/plasma/wallpapers/${_gitname}/.git"
+}
+
+# vim: set ts=2 sw=2 ft=sh noet: