summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9f4c3b698ff..124229793c9a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = playit
pkgdesc = A tunneling tool to host a game server without port forwarding or sharing public IP
- pkgver = v0.9.3+1+g94712ee
- pkgrel = 2
+ pkgver = v1.0.0+rc2+1+g185bfb0
+ pkgrel = 1
url = https://playit.gg
arch = x86_64
license = BSD
makedepends = git
makedepends = cargo
+ depends = glibc
depends = gcc-libs
- source = playit::git+https://github.com/playit-cloud/playit-agent.git#commit=94712eea624b609e7b97829262b53a0e589e527a
+ source = playit::git+https://github.com/playit-cloud/playit-agent.git#commit=185bfb0a75d3af75d915c84fa1bcd514653220f1
sha256sums = SKIP
pkgname = playit
diff --git a/PKGBUILD b/PKGBUILD
index 30791dedb5e6..c45a4a191285 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,15 @@
# Maintainer: Amirul Fitri <tounghacker@gmail.com>
# maintainer's variables
-_commit=94712eea624b609e7b97829262b53a0e589e527a
+_commit=185bfb0a75d3af75d915c84fa1bcd514653220f1
pkgname=playit
-pkgver=v0.9.3+1+g94712ee
-pkgrel=2
+pkgver=v1.0.0+rc2+1+g185bfb0
+pkgrel=1
pkgdesc="A tunneling tool to host a game server without port forwarding or sharing public IP"
arch=('x86_64')
url="https://playit.gg"
-depends=('gcc-libs')
+depends=('glibc' 'gcc-libs')
license=('BSD')
makedepends=('git' 'cargo')
source=("${pkgname}::git+https://github.com/playit-cloud/playit-agent.git#commit=${_commit}")
@@ -17,7 +17,7 @@ sha256sums=('SKIP')
prepare() {
cd "${pkgname}"
- cargo update # FIXME: remove later when upstream update Cargo.lock
+ #cargo update # FIXME: remove later when upstream update Cargo.lock
cargo fetch --locked --target "${CARCH}-unknown-linux-gnu"
}
@@ -36,11 +36,11 @@ build() {
check() {
cd "${pkgname}"
export RUSTUP_TOOLCHAIN=stable
- cargo test --frozen --all-features
+ #cargo test --frozen --all-features # FIXME: build failed, when enable check! :(
}
package() {
cd "${pkgname}"
- install -Dm755 target/release/agent "${pkgdir}"/usr/bin/"${pkgname}"
+ install -Dm755 target/release/playit-cli "${pkgdir}"/usr/bin/"${pkgname}"
install -Dm644 LICENSE.txt "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
}