summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD9
-rwxr-xr-xPlayOnLinux.sh15
3 files changed, 12 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8e695491b900..8e92164fd921 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = playonlinux5-git
pkgdesc = GUI for managing Windows programs under linux (development version based on Java)
- pkgver = r1319.66f20455
- pkgrel = 1
+ pkgver = r1328.6376ad23
+ pkgrel = 3
epoch = 2
url = http://www.playonlinux.com/
arch = any
@@ -18,7 +18,7 @@ pkgbase = playonlinux5-git
source = PlayOnLinux.sh
sha256sums = SKIP
sha256sums = 4703fc813fb18d3e414cc1483f03cb3c0c306e5725b7681b3dbc43fb7f6630de
- sha256sums = 7558a8d24f344228ec55fc9fd156dfe75d7625378c6230fa2a625fa8fe17ee12
+ sha256sums = 9deabf8918a55e5726d9708e074a3420701f89f57748779f78a8ee681fbe97e4
pkgname = playonlinux5-git
diff --git a/PKGBUILD b/PKGBUILD
index e6feb07bb2e0..7cef647a0a52 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -10,8 +10,8 @@
_pkgname=playonlinux5
pkgname=$_pkgname-git
-pkgver=r1319.66f20455
-pkgrel=1
+pkgver=r1328.6376ad23
+pkgrel=3
epoch=2
pkgdesc="GUI for managing Windows programs under linux (development version based on Java)"
arch=('any')
@@ -28,7 +28,7 @@ source=(
sha256sums=(
'SKIP'
'4703fc813fb18d3e414cc1483f03cb3c0c306e5725b7681b3dbc43fb7f6630de'
- '7558a8d24f344228ec55fc9fd156dfe75d7625378c6230fa2a625fa8fe17ee12'
+ '9deabf8918a55e5726d9708e074a3420701f89f57748779f78a8ee681fbe97e4'
)
pkgver() {
@@ -46,9 +46,6 @@ build() {
# Use path to Java 8 for users nkt defaulted to Java 8 yet
export JAVA_HOME="/usr/lib/jvm/java-8-openjdk"
- # Clean up
- mvn clean
-
# Build
mvn package
diff --git a/PlayOnLinux.sh b/PlayOnLinux.sh
index 0ae1b310c9dd..719c33efc08a 100755
--- a/PlayOnLinux.sh
+++ b/PlayOnLinux.sh
@@ -3,13 +3,10 @@
POL_HOME=/opt/playonlinux5
CLASSPATH=${CLASSPATH}:$POL_HOME/lib/*
-# Ensure we are using the right java env
-# Don't necessarily force default Java 8, as it is not the default for Arch Linux right now
-# This handles users with Java 7 and 8
-export PATH=/usr/lib/jvm/java-8-openjdk/jre/bin/:$PATH
+if [[ $(archlinux-java get | cut -d "-" -f2) -ge 8 ]]; then
+ export JAVA_HOME=$(archlinux-java get)
+else
+ export JAVA_HOME=$(ls /usr/lib/jvm/java-{8,9}-*/bin/javac 2>/dev/null | cut -d "/" -f-5 | head -1)
+fi
-java -classpath "$CLASSPATH" com.playonlinux.app.PlayOnLinuxApp "$@"
-
-# Unset vars?
-# Note: Java version can be sourced with this one liner:
-# IFS=\" read -r _ version _ < <(java -version 2>&1); printf %s\\n "$version
+java -classpath "$CLASSPATH" com.playonlinux.javafx.JavaFXApplication "$@"