summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rwxr-xr-x.SRCINFO11
-rwxr-xr-xPKGBUILD33
-rwxr-xr-xplotxy12
-rwxr-xr-xplotxy.desktop9
-rwxr-xr-xplotxy.pngbin0 -> 19621 bytes
5 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100755
index 000000000000..fb1faf795670
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = plotxy
+ pkgdesc = A plotting and post-processing program developed by prof. Massimo Ceraolo from the University of Pisa, as part of his research activities involving simulation and post-processing of measured data
+ pkgver = nov2018
+ pkgrel = 1
+ url = http://ceraolo-plotxy.ing.unipi.it/default.htm
+ arch = x86_64
+ license = GPL3
+ source = http://ceraolo-plotxy.ing.unipi.it/PlotXY_Download/PlotXY-2018-Nov-Linux.zip
+ sha256sums = 62876fb6329de24a09c7088ef70976ec726d409041cfa9c28d163b8483df1306
+
+pkgname = plotxy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..7688aecbdd3b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Daniel Barbosa <dbarbosa0 at gmail dot com>
+
+pkgname=plotxy
+pkgver=nov2018
+pkgrel=1
+pkgdesc="A plotting and post-processing program developed by prof. Massimo Ceraolo from the University of Pisa, as part of his research activities involving simulation and post-processing of measured data"
+arch=('x86_64')
+url="http://ceraolo-plotxy.ing.unipi.it/default.htm"
+license=(GPL3)
+depends=()
+conflicts=()
+source=(http://ceraolo-plotxy.ing.unipi.it/PlotXY_Download/PlotXY-2018-Nov-Linux.zip)
+sha256sums=('62876fb6329de24a09c7088ef70976ec726d409041cfa9c28d163b8483df1306')
+
+package() {
+
+ cd "$srcdir"/PlotXY-2018-Nov-Linux
+ chmod +x PlotXY.AppImage
+ ./PlotXY.AppImage --appimage-extract
+ cd squashfs-root
+ install -d "$pkgdir"/opt/$pkgname
+ cp PlotXY "$pkgdir"/opt/$pkgname
+ install -d "$pkgdir"/usr/local/bin/
+
+
+ install -Dm644 "${startdir}/plotxy.desktop" "${pkgdir}/usr/share/applications/plotxy.desktop"
+ install -Dm644 "${startdir}/plotxy.png" "${pkgdir}/usr/share/pixmaps/plotxy.png"
+ install -Dm755 "${startdir}/plotxy" "${pkgdir}/opt/${pkgname}"
+
+ ln -s /opt/$pkgname/plotxy "$pkgdir"/usr/local/bin/plotxy
+
+}
+
diff --git a/plotxy b/plotxy
new file mode 100755
index 000000000000..30466cb1b050
--- /dev/null
+++ b/plotxy
@@ -0,0 +1,12 @@
+#!/bin/sh
+# script to run PlotXY
+# usage:
+# runplotxy file <enter>
+#
+cd ${1%/*}
+
+/opt/plotxy/PlotXY ${1##*/}
+
+
+
+
diff --git a/plotxy.desktop b/plotxy.desktop
new file mode 100755
index 000000000000..be2ed314dd3b
--- /dev/null
+++ b/plotxy.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Encoding=UTF-8
+Type=Application
+Exec=plotxy %U
+Comment=A plotting and post-processing program
+Terminal=false
+Name=PlotXY
+Icon=/usr/share/pixmaps/plotxy.png
+Categories=Science;Education;
diff --git a/plotxy.png b/plotxy.png
new file mode 100755
index 000000000000..266a873bd3a8
--- /dev/null
+++ b/plotxy.png
Binary files differ