summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD40
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8a8f71d7819
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = plujain-ramp-git
+ pkgdesc = Mono rhythmic tremolo LV2 plugin with no GUI
+ pkgver = r47.9568cc9
+ pkgrel = 1
+ url = https://github.com/Houston4444/plujain-ramp
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = lv2
+ provides = plujain-ramp
+ provides = plujain-ramp-git
+ conflicts = plujain-ramp
+ conflicts = plujain-ramp-git
+ source = git+https://github.com/Houston4444/plujain-ramp
+ md5sums = SKIP
+
+pkgname = plujain-ramp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f0dd422a60d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Milk Brewster <milk on freenode>
+_pkgname=plujain-ramp
+pkgname=${_pkgname}-git
+pkgver=r47.9568cc9
+pkgrel=1
+pkgdesc="Mono rhythmic tremolo LV2 plugin with no GUI"
+arch=(x86_64)
+url="https://github.com/Houston4444/plujain-ramp"
+license=('GPL')
+groups=()
+depends=('lv2')
+makedepends=('git')
+provides=('plujain-ramp' 'plujain-ramp-git')
+conflicts=('plujain-ramp' 'plujain-ramp-git')
+install=
+source=('git+https://github.com/Houston4444/plujain-ramp')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/plujain-ramp"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+prepare() {
+ cd "$srcdir/plujain-ramp"
+}
+
+build() {
+ cd "$srcdir/plujain-ramp"
+ make clean && make
+}
+
+package() {
+ cd "$srcdir/plujain-ramp"
+ make INSTALL_PATH=${pkgdir}/usr/lib/lv2 install
+}