summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD22
3 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f184e96ec251
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = plymouth-theme-neat
+ pkgdesc = HiDPI-Friendly Plymouth Theme for Arch Linux
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/neetly/plymouth-theme-neat
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = plymouth
+ source = plymouth-theme-neat::git+https://github.com/neetly/plymouth-theme-neat.git#tag=v0.1.0
+ cksums = SKIP
+
+pkgname = plymouth-theme-neat
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..91f1c1027e95
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ea8b81c3be8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Hikari Hayashi <rev.hikari@gmail.com>
+
+pkgname=plymouth-theme-neat
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="HiDPI-Friendly Plymouth Theme for Arch Linux"
+url="https://github.com/neetly/plymouth-theme-neat"
+license=(MIT)
+arch=(any)
+depends=(plymouth)
+makedepends=(git)
+source=("$pkgname::git+https://github.com/neetly/plymouth-theme-neat.git#tag=v$pkgver")
+cksums=(SKIP)
+
+package() {
+ cd "$srcdir/$pkgname"
+ (
+ cd ./src
+ find . -exec install -Dm644 "{}" "$pkgdir/usr/share/plymouth/themes/neat/{}" \;
+ )
+ install -Dm644 "./LICENSE" "$pkgdir/usr/share/licenses/plymouth-theme-neat/LICENSE"
+}