summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD24
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ffa001add443..3e0a26157740 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
pkgbase = pokemon-revolution-online-bin
pkgdesc = A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games.
- pkgver = 0.98.5.20200913_0.3.1.megav2
+ pkgver = 20200821+0.3.2+0.98.5
pkgrel = 1
- url = https://pokemon-revolution-online.net
+ url = https://pokemonrevolution.net
install = archlinux.install
arch = x86_64
license = custom
- makedepends = xdg-utils
- depends = desktop-file-utils
+ depends = vulkan-driver
+ depends = opengl-driver
optdepends = gtk2: required for the Unity ScreenSelector plugin
conflicts = pokemon-revolution-online
- source = https://gitlab.com/fabis_cafe/pokemon-revolution-online-data/-/archive/0.3.1/pokemon-revolution-online-data-0.3.1.zip
+ source = git+https://gitlab.com/fabis_cafe/pro_assets_lin_desktop.git#tag=0.3.2
source = PROClient_linux.7z::https://ddl.pokemonrevolution.net/PROClient_linux.7z
- sha256sums = ab38844feddb7b3df18ad7149272b908c63ecc5c654005188cfaf9db5b05b3c4
+ sha256sums = SKIP
sha256sums = 9b127ad358bf3f0fbe72271cb31b465a01d422a09f5715adaa7755e2adfd85a3
pkgname = pokemon-revolution-online-bin
diff --git a/PKGBUILD b/PKGBUILD
index cfb172e17b89..12c797c96361 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,22 @@
# Maintainer: Fabian <plusfabi[AT+thegoogleadress]>
pkgname=pokemon-revolution-online-bin
-__DATA_VER=0.3.1
-pkgver=0.98.5.20200913_${__DATA_VER}.megav2
+__LIN_DESKTOP_ASSET_VER=0.3.2
+__PROCLIENT_VER=0.98.5
+pkgver=20200821+${__LIN_DESKTOP_ASSET_VER}+${__PROCLIENT_VER}
pkgrel=1
pkgdesc="A free-to-play, fan-made, MMO game that is predicated around the official Pokémon games."
arch=('x86_64')
-url="https://pokemon-revolution-online.net"
+url="https://pokemonrevolution.net"
license=('custom')
-depends=('desktop-file-utils')
-makedepends=('xdg-utils')
+depends=('vulkan-driver' 'opengl-driver')
optdepends=('gtk2: required for the Unity ScreenSelector plugin')
conflicts=('pokemon-revolution-online')
-install=$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install
-source=("https://gitlab.com/fabis_cafe/pokemon-revolution-online-data/-/archive/${__DATA_VER}/pokemon-revolution-online-data-${__DATA_VER}.zip"
+install="$(/usr/bin/tail -n 1 /usr/lib/os-release | /usr/bin/cut -d= -f2).install"
+source=("git+https://gitlab.com/fabis_cafe/pro_assets_lin_desktop.git#tag=${__LIN_DESKTOP_ASSET_VER}"
"PROClient_linux.7z::https://ddl.pokemonrevolution.net/PROClient_linux.7z"
)
-sha256sums=('ab38844feddb7b3df18ad7149272b908c63ecc5c654005188cfaf9db5b05b3c4'
+sha256sums=('SKIP'
'9b127ad358bf3f0fbe72271cb31b465a01d422a09f5715adaa7755e2adfd85a3')
package() {
@@ -49,18 +49,18 @@ package() {
#MOVE ICON
## The original icon is proprietary with a license that don't allows changes to the overall content.
## Don't use the original icon for the '.desktop entry because of this.
- /usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/net.pokemonrevolution.svg" \
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/net.pokemonrevolution.svg" \
"${pkgdir}/usr/share/pixmaps/net.pokemonrevolution.svg"
# DESKTOP FILE
- /usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/net.pokemonrevolution.desktop" \
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/net.pokemonrevolution.desktop" \
"${pkgdir}/usr/share/applications/net.pokemonrevolution.desktop"
# START SCRIPT
- /usr/bin/install -D -m755 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/PROClient" \
+ /usr/bin/install -D -m755 "${srcdir}/pro_assets_lin_desktop/PROClient" \
"${pkgdir}/usr/bin/PROClient"
# COPYRIGHT FILE
- /usr/bin/install -D -m644 "${srcdir}/pokemon-revolution-online-data-${__DATA_VER}/pkg_copyright" \
+ /usr/bin/install -D -m644 "${srcdir}/pro_assets_lin_desktop/pkg_copyright" \
"${pkgdir}/usr/share/licenses/pokemon-revolution-online-bin/copyright"
}