summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD30
2 files changed, 19 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6ffbf85afc4c..8ccee1a69830 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,16 @@
-# Generated by mksrcinfo v8
-# Sat Jan 16 21:08:14 UTC 2016
pkgbase = polyglot-winboard-git
pkgdesc = UCI/USI/UCCI to XBoard adapter (WinBoard fork)
- pkgver = d86ce4e
- pkgrel = 1
+ pkgver = r44.5904a29
+ pkgrel = 3
epoch = 1
url = http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=summary
arch = i686
arch = x86_64
license = GPL2
- depends = glibc
- provides = polyglot
- conflicts = polyglot
- replaces = polyglot
- source = polyglot.tar.gz::http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=snapshot;h=refs/heads/learn;sf=tgz
+ makedepends = git
+ provides = polyglot-winboard=r44.5904a29
+ conflicts = polyglot-winboard
+ source = git+http://hgm.nubati.net/git/polyglot.git
md5sums = SKIP
pkgname = polyglot-winboard-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 12fc4b1fcba9..87cf7c143b68 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,36 @@
# Maintainer: Jakob Gahde <j5lx@fmail.co.uk>
+_srcname=polyglot
+_pkgname=polyglot-winboard
pkgname=polyglot-winboard-git
-pkgver=d86ce4e
-pkgrel=1
+pkgver=r44.5904a29
+pkgrel=3
epoch=1
pkgdesc="UCI/USI/UCCI to XBoard adapter (WinBoard fork)"
arch=('i686' 'x86_64')
url="http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=summary"
license=('GPL2')
-depends=('glibc')
-provides=('polyglot')
-conflicts=('polyglot')
-replaces=('polyglot')
-# If anyone knows the URL of the actual repository, please tell me!
-source=("polyglot.tar.gz::http://hgm.nubati.net/cgi-bin/gitweb.cgi?p=polyglot.git;a=snapshot;h=refs/heads/learn;sf=tgz")
+makedepends=('git')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("${_pkgname}")
+source=("git+http://hgm.nubati.net/git/${_srcname}.git")
md5sums=('SKIP')
-_enter_polyglot_directory() {
- cd $(ls -lt --color=never $srcdir | grep '^d' | grep -Eo 'polyglot-learn-[a-f0-9]+$' | head -n1)
-}
-
pkgver() {
- _enter_polyglot_directory
+ cd "${srcdir}/${_srcname}"
- pwd | grep -Po '[a-f0-9]+$'
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
build() {
- _enter_polyglot_directory
+ cd "${srcdir}/${_srcname}"
./configure --prefix=/usr
- make
+ make CFLAGS="$CFLAGS -fcommon"
}
package() {
- _enter_polyglot_directory
+ cd "${srcdir}/${_srcname}"
make DESTDIR="${pkgdir}" install
}