summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD52
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..265c4ca26117
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pom
+ pkgdesc = Display the phase of the moon.
+ pkgver = 0.14
+ pkgrel = 1
+ url = http://search.cpan.org/dist/ppt/bin/pom
+ arch = any
+ license = GPL2
+ depends = perl
+ source = http://search.cpan.org/CPAN/authors/id/C/CW/CWEST/ppt-0.14.tar.gz
+ sha512sums = 3df3faa027002bfa2e9b774a9ca112d12ae01cb1142208ae6ffcd38b96bba03e73d76c38e6f0f93901ad1b54a99f4c09478718edcf7eab1b5c0a51f61051d467
+
+pkgname = pom
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b55ac886bd70
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+#!/bin/bash
+### Above line for automatic syntax highlighting editors.
+
+# Maintainer: Felix Becker <felix )dot( becker (at( zih )dot) tu-dresden |dot| de>.
+
+pkgname="pom"
+pkgver="0.14"
+pkgrel="1"
+pkgdesc="Display the phase of the moon."
+arch=('any')
+url='http://search.cpan.org/dist/ppt/bin/pom'
+depends=('perl')
+license=('GPL2')
+source=("http://search.cpan.org/CPAN/authors/id/C/CW/CWEST/ppt-${pkgver}.tar.gz")
+
+sha512sums=('3df3faa027002bfa2e9b774a9ca112d12ae01cb1142208ae6ffcd38b96bba03e73d76c38e6f0f93901ad1b54a99f4c09478718edcf7eab1b5c0a51f61051d467')
+
+
+build()
+{
+ _extractdir="${srcdir}/ppt-${pkgver}"
+ echo ""
+ echo ">>> Building '${pkgname}', version '${pkgver}'. >>>"
+ echo ""
+
+ cd "${_extractdir}" || exit 11
+
+ perl Makefile.PL PREFIX=/usr || exit "$?"
+ make || exit "$?"
+
+ echo ""
+ echo "<<< Finished building '${pkgname}', version '${pkgver}'. <<<"
+ echo ""
+}
+
+package()
+{
+ _extractdir="${srcdir}/ppt-${pkgver}"
+ _instdir="/usr/bin"
+ _docinstdir="/usr/share/doc/${pkgname}"
+
+ cd "${_extractdir}"
+
+ mkdir -p "${pkgdir}/${_instdir}" || exit 21
+ mkdir -p "${pkgdir}/${_docinstdir}" || exit 22
+
+ ### Only install 'pom'.
+ cp -v bin/pom "${pkgdir}/${_instdir}" || exit "$?"
+
+ cp -av html/commands/pom "${pkgdir}/${_docinstdir}/html" || exit "$?"
+}
+