summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore11
-rwxr-xr-xPKGBUILD29
-rwxr-xr-xpony-creator.desktop10
-rwxr-xr-xpony-creator.pngbin0 -> 5614 bytes
-rwxr-xr-xpony-creator.sh2
6 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..339f7cbaee2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pony-creator
+ pkgdesc = Create your own pony character inspired by My Little Pony: Friendship is Magic (Flash game)
+ pkgver = v3
+ pkgrel = 1
+ url = http://generalzoi.deviantart.com/art/Pony-Creator-v3-397808116
+ arch = any
+ license = unknown
+ depends = flashplayer-standalone>=10
+ source = Pony-creator.swf::http://fc03.deviantart.com/fs71/f/2013/245/2/9/298852eef0c2257d49084ad7dbea67a8-d6kuepg.swf
+ source = pony-creator.png
+ source = pony-creator.desktop
+ source = pony-creator.sh
+ md5sums = e91c4507d0ac624739f72253a81fd500
+ md5sums = 50718b321060ad225712da27900dd2e6
+ md5sums = 3316779fcd080b8eb067c261262a3929
+ md5sums = 40777f3b610db65dec21d52e6ec98b5e
+
+pkgname = pony-creator
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7d813751c966
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,11 @@
+src
+srcdir
+pkg
+pkgdir
+*.tar.*
+*.xz
+*.gz
+*.bz2
+*.tar
+*.zip
+*.rar
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..f0b5afd5809b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Contributor: Schala Zeal <schalaalexiazeal@gmail.com>
+# Maintainer: Pablo Lezaeta <prflr88@gmail.com>
+
+## Uploaded with permission from the author ##
+
+pkgname=pony-creator
+pkgver=v3
+pkgrel=1
+pkgdesc="Create your own pony character inspired by My Little Pony: Friendship is Magic (Flash game)"
+arch=(any)
+url="http://generalzoi.deviantart.com/art/Pony-Creator-v3-397808116"
+license=("unknown")
+depends=("flashplayer-standalone>=10")
+source=("Pony-creator.swf::http://fc03.deviantart.com/fs71/f/2013/245/2/9/298852eef0c2257d49084ad7dbea67a8-d6kuepg.swf"
+ "pony-creator.png"
+ "pony-creator.desktop"
+ "pony-creator.sh")
+
+package() {
+ install -Dm644 "${srcdir}/Pony-creator.swf" "${pkgdir}/usr/share/games/${pkgname}/Pony-Creator-v3.swf"
+ install -Dm755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -Dm644 "${srcdir}/pony-creator.png" "${pkgdir}/usr/share/icons/${pkgname}.png"
+}
+
+md5sums=('e91c4507d0ac624739f72253a81fd500'
+ '50718b321060ad225712da27900dd2e6'
+ '3316779fcd080b8eb067c261262a3929'
+ '40777f3b610db65dec21d52e6ec98b5e')
diff --git a/pony-creator.desktop b/pony-creator.desktop
new file mode 100755
index 000000000000..f8e8c063e7db
--- /dev/null
+++ b/pony-creator.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Pony Creator
+GenericName=Pony Creator
+Comment=Create your own pony character inspired by My Little Pony: Friendship is Magic
+Version=1.0
+Type=Application
+Terminal=false
+Icon=pony-creator
+Exec=pony-creator
+Categories=Game;
diff --git a/pony-creator.png b/pony-creator.png
new file mode 100755
index 000000000000..4ff167ff013f
--- /dev/null
+++ b/pony-creator.png
Binary files differ
diff --git a/pony-creator.sh b/pony-creator.sh
new file mode 100755
index 000000000000..6efe97c92f61
--- /dev/null
+++ b/pony-creator.sh
@@ -0,0 +1,2 @@
+#!/usr/bin/env bash
+flashplayer /usr/share/games/pony-creator/Pony-Creator-v3.swf --class $(basename "${0%.*}") "$@"