summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4b704102bbec
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = postgresql-unit-git
+ pkgdesc = SI Units for PostgreSQL
+ pkgver = 4.0.r2.g7845111
+ pkgrel = 1
+ url = https://github.com/ChristophBerg/postgresql-unit
+ arch = any
+ license = GPL3
+ makedepends = postgresql-libs
+ makedepends = git
+ depends = postgresql
+ source = git+https://github.com/ChristophBerg/postgresql-unit
+ sha1sums = SKIP
+
+pkgname = postgresql-unit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e10f98182afc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: vltr <rkuesters@gmail.com>
+pkgname=postgresql-unit-git
+pkgver=4.0.r2.g7845111
+pkgrel=1
+pkgdesc="SI Units for PostgreSQL"
+url="https://github.com/ChristophBerg/postgresql-unit"
+arch=('any')
+license=('GPL3')
+depends=('postgresql')
+makedepends=('postgresql-libs' git)
+source=(git+https://github.com/ChristophBerg/postgresql-unit)
+sha1sums=('SKIP')
+
+pkgver() {
+ cd postgresql-unit
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd postgresql-unit
+ make
+}
+
+package() {
+ cd postgresql-unit
+ make DESTDIR=${pkgdir} install
+}