summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD45
-rw-r--r--ppf-scripts.install27
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5b8fad2e88fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+# Generated by makepkg 5.0.1
+# Wed Mar 16 19:05:54 UTC 2016
+pkgbase = ppf-scripts
+ pkgdesc = Collection of PGP Filters for pine/alpine created by Douglas Barton.
+ pkgver = 1.8
+ pkgrel = 1
+ url = https://dougbarton.us/PGP/ppf/
+ install = ppf-scripts.install
+ arch = any
+ license = BSD
+ depends = gnupg
+ source = https://dougbarton.us/PGP/ppf/pine-pgp-filters-1.8.tar.gz
+ sha256sums = 4967cc0bb6a3872e582f586c794ed952a126195cb8940035a0828dcd1f863b25
+
+pkgname = ppf-scripts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3a42b3a6667a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Étienne Deparis <etienne@depar.is>
+
+pkgname=ppf-scripts
+_upstreamname=pine-pgp-filters
+pkgver=1.8
+pkgrel=1
+pkgdesc='Collection of PGP Filters for pine/alpine created by Douglas Barton.'
+arch=('any')
+url='https://dougbarton.us/PGP/ppf/'
+license=('BSD')
+depends=('gnupg')
+source=('https://dougbarton.us/PGP/ppf/pine-pgp-filters-1.8.tar.gz')
+sha256sums=('4967cc0bb6a3872e582f586c794ed952a126195cb8940035a0828dcd1f863b25')
+install='ppf-scripts.install'
+
+build() {
+ cd "$srcdir/${_upstreamname}-${pkgver}"
+ chmod -R u+w .
+ #for file in scripts/*; do
+ # sed -i -e 's|@@PREFIX@@/bin|/usr/lib/ppf-scripts|g' \
+ # -e 's|@@GPG@@|/usr/bin/gpg|g' \
+ # $file
+ #done
+ sed -i "s|libexec|lib/${pkgname}|g" configure
+ sed -i -e "s|libexec|lib/${pkgname}|g" \
+ -e 's|s#\\@\\@PREFIX\\@\\@#@@PREFIX@@#g|s#\\@\\@PREFIX\\@\\@/bin#/usr/lib/ppf-scripts#g|' \
+ -e 's|s#\\@\\@GPG\\@\\@#@@GPG@@#g|s#\\@\\@GPG\\@\\@#/usr/bin/gpg#g|' \
+ -e 's|ln -sf @@PREFIX@@|ln -sf /usr|g' Makefile.in
+ ./configure --prefix="$pkgdir/usr"
+}
+
+package() {
+ install -d -m755 "${pkgdir}/usr/share/licenses/${pkgname}"
+ install -d -m755 "${pkgdir}/usr/share/doc/${pkgname}"
+
+ cd "$srcdir/${_upstreamname}-${pkgver}"
+ make install
+
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+
+ install -D -m644 BUGS "${pkgdir}/usr/share/doc/${pkgname}/BUGS"
+ install -D -m644 CHANGES "${pkgdir}/usr/share/doc/${pkgname}/CHANGES"
+ install -D -m644 INSTALL "${pkgdir}/usr/share/doc/${pkgname}/INSTALL"
+ install -D -m644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
+}
diff --git a/ppf-scripts.install b/ppf-scripts.install
new file mode 100644
index 000000000000..78cc9f0b7859
--- /dev/null
+++ b/ppf-scripts.install
@@ -0,0 +1,27 @@
+post_install() {
+ echo ''
+ echo 'Contrary to upstream configuration, ppf-scripts are installed'
+ echo 'in /usr/bin and /usr/lib/ppf-scripts.'
+ echo ''
+ echo 'To make use of them you will have to modify your Alpine'
+ echo 'config. First make a backup of your config, then start Alpine'
+ echo "and type M for \"Menu\" (if you're not already there), S for"
+ echo '"Setup" and C for "Config". To verify and/or decrypt files'
+ echo 'put the following in your display-filters option, exactly as'
+ echo 'shown:'
+ echo ''
+ echo "_LEADING(\"-----BEGIN PGP SIGNED \")_ /usr/lib/ppf-scripts/ppf_verify _TMPFILE_"
+ echo "_LEADING(\"-----BEGIN PGP MESSAGE\")_ /usr/lib/ppf-scripts/ppf_decrypt _TMPFILE_"
+ echo ''
+ echo 'To sign and/or encrypt messages that you send, put the'
+ echo 'following in your sending-filters option:'
+ echo ''
+ echo '/usr/lib/ppf-scripts/ppf_sign _INCLUDEALLHDRS_'
+ echo '/usr/lib/ppf-scripts/ppf_encrypt _INCLUDEALLHDRS_ _RECIPIENTS_'
+ echo ''
+ echo 'For more information, please refer to /usr/share/doc/ppf-scripts/INSTALL'
+}
+
+post_upgrade() {
+ post_install
+}