summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD35
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..568303611f7e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = proid-git
+ pkgdesc = A tool to hide and show windows in X
+ pkgver = r11.480742a
+ pkgrel = 1
+ url = https://gitlab.com/rehposuite/proid
+ arch = any
+ license = GPL
+ makedepends = stack
+ depends = xdotool
+ provides = proid
+ source = git+https://gitlab.com/rehposuite/proid.git
+ sha256sums = SKIP
+
+pkgname = proid-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1c005feea262
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Christopher <archlinux-maintainer@christopherz.com>
+
+pkgname="proid-git"
+pkgver=r11.480742a
+pkgrel=1
+pkgdesc="A tool to hide and show windows in X"
+arch=("any")
+url="https://gitlab.com/rehposuite/proid"
+license=("GPL")
+depends=("xdotool")
+makedepends=("stack")
+provides=("proid")
+source=("git+${url}.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "proid"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short=7 HEAD)"
+}
+
+build() {
+ cd "proid"
+
+ stack setup
+ stack build
+}
+
+package() {
+ cd "proid"
+
+ find ./ -path '*/dist/*' -type f -name proid -perm /u+x \
+ -execdir install -Dm755 -t "$pkgdir/usr/bin/" {} \;
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}