summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--proton-sanitize_makefile.patch33
3 files changed, 15 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1ba616c0c0e8..5117ebd7e651 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -250,7 +250,7 @@ pkgbase = proton
sha256sums = 9212a9c42ac8c9c7b9ba7378685b27e7ea0e7a8a8aaac1f3f4d37590ada3e991
sha256sums = b4e9c0c4959fcb3f7b7f25e35e5e0577dac5d54fe18e6edb15852a2a4196f2a2
sha256sums = 9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215
- sha256sums = 8399d0684a9c732bf405a37f1f3cc779435f2c68a8d042382e9e0538576ab854
+ sha256sums = 2310147ad56cca7ea47bfc1d36a645fae1ffaf34a4a677509935336af4eb0d3e
sha256sums = 8be5e0ae9f71d686c72ac094a4eaca14ea288276195d4c0c217a4f3974fbcc70
sha256sums = 20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3
sha256sums = 958f8e69bc789cc8fbe58cb6c9fc62f065692c3c165f20b0c21133ce94bad736
diff --git a/PKGBUILD b/PKGBUILD
index 990775508068..71a13a3112f8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -282,7 +282,7 @@ build() {
export RUSTUP_TOOLCHAIN=stable
export WINEESYNC=0
export WINEFSYNC=0
- export DISPLAY=""
+ export DISPLAY=
SUBJOBS=$([[ "$MAKEFLAGS" =~ -j\ *([1-9][0-9]*) ]] && echo "${BASH_REMATCH[1]}" || echo "$(nproc)") \
make -j1 dist
}
@@ -347,7 +347,7 @@ sha256sums=('SKIP'
'9212a9c42ac8c9c7b9ba7378685b27e7ea0e7a8a8aaac1f3f4d37590ada3e991'
'b4e9c0c4959fcb3f7b7f25e35e5e0577dac5d54fe18e6edb15852a2a4196f2a2'
'9005d8169266ba0b93be30e1475fe9a3697464796f553886c155ec1d77d71215'
- '8399d0684a9c732bf405a37f1f3cc779435f2c68a8d042382e9e0538576ab854'
+ '2310147ad56cca7ea47bfc1d36a645fae1ffaf34a4a677509935336af4eb0d3e'
'8be5e0ae9f71d686c72ac094a4eaca14ea288276195d4c0c217a4f3974fbcc70'
'20f7cd3e70fad6f48d2f1a26a485906a36acf30903bf0eefbf82a7c400e248f3'
'958f8e69bc789cc8fbe58cb6c9fc62f065692c3c165f20b0c21133ce94bad736')
diff --git a/proton-sanitize_makefile.patch b/proton-sanitize_makefile.patch
index e63b6912bef1..d1b4cd61f22c 100644
--- a/proton-sanitize_makefile.patch
+++ b/proton-sanitize_makefile.patch
@@ -1,5 +1,5 @@
diff --git a/build/makefile_base.mak b/build/makefile_base.mak
-index d978a99..9502e3c 100644
+index d978a99..3bd983d 100644
--- a/build/makefile_base.mak
+++ b/build/makefile_base.mak
@@ -63,7 +63,6 @@ ifeq ($(ENABLE_CCACHE),1)
@@ -10,6 +10,15 @@ index d978a99..9502e3c 100644
DOCKER_OPTS := $(CCACHE_ENV) -e CCACHE_DISABLE=1 $(DOCKER_OPTS)
endif
+@@ -121,7 +120,7 @@ container-build:
+ all32 $(MAKECMDGOALS32): container-build
+ all64 $(MAKECMDGOALS64): container-build
+ else
+-J = $(patsubst -j%,%,$(filter -j%,$(MAKEFLAGS)))
++J = $(patsubst -j%,%,$(SUBJOBS))
+ endif
+
+
@@ -171,7 +170,8 @@ else
endif
@@ -142,18 +151,9 @@ index 5369fb4..21db917 100644
endif
endef
diff --git a/make/rules-cmake.mk b/make/rules-cmake.mk
-index 4c61951..3a31610 100644
+index 4c61951..3f3a62b 100644
--- a/make/rules-cmake.mk
+++ b/make/rules-cmake.mk
-@@ -15,7 +15,7 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/CMakeLists.txt
- cmake "$$($(2)_SRC)" \
- -DCMAKE_INSTALL_PREFIX="$$($(2)_DST$(3))" \
- -DCMAKE_INSTALL_LIBDIR="lib$(subst 32,,$(3))" \
-- -DCMAKE_BUILD_TYPE=plain \
-+ -DCMAKE_BUILD_TYPE=Release \
- $$($(2)_CMAKE_ARGS) \
- $$($(2)_CMAKE_ARGS$(3))
-
@@ -24,9 +24,9 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/CMakeLists.txt
$$(OBJ)/.$(1)-build$(3):
@echo ":: building $(3)bit $(1)..." >&2
@@ -195,7 +195,7 @@ index 916df8b..044f705 100644
LD_LIBRARY_PATH="$$(call list-join,:,$$(foreach d,$$($(2)_DEPS$(3)),$$($$(d)_LIBDIR$(3))),,:)$$$$LD_LIBRARY_PATH" \
PKG_CONFIG_PATH="$$(call list-join,:,$$(foreach d,$$($(2)_DEPS$(3)),$$($$(d)_LIBDIR$(3))/pkgconfig))" \
diff --git a/make/rules-meson.mk b/make/rules-meson.mk
-index 7b982fa..8e08128 100644
+index 7b982fa..a4fde46 100644
--- a/make/rules-meson.mk
+++ b/make/rules-meson.mk
@@ -11,7 +11,7 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/meson.build
@@ -207,15 +207,6 @@ index 7b982fa..8e08128 100644
sed -e "s:\[properties\]:[properties]\nc_args = [$$(call list-quote,$$(COMMON_FLAGS))]:" \
-e "s:\[properties\]:[properties]\ncpp_args = [$$(call list-quote,$$(COMMON_FLAGS))]:" \
-e "s:\[properties\]:[properties]\nlink_args = [$$(call list-quote,$$(CROSSLDFLAGS))]:" \
-@@ -21,7 +21,7 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/meson.build
- meson "$$($(2)_OBJ$(3))" "$$($(2)_SRC)" \
- --prefix="$$($(2)_DST$(3))" \
- --libdir="lib$(subst 32,,$(3))" \
-- --buildtype=plain \
-+ --buildtype=release \
- $$($(2)_MESON_ARGS) \
- $$($(2)_MESON_ARGS$(3)) \
- $$(MESON_STRIP_ARG)
@@ -31,7 +31,7 @@ $$(OBJ)/.$(1)-configure$(3): $$($(2)_SRC)/meson.build
$$(OBJ)/.$(1)-build$(3):
@echo ":: building $(3)bit $(1)..." >&2